A4 arpeggiator p-lock?

Apologies if this has been discussed before - I have a feeling it has, but could not find relevant results using the search function. If so, I’d be happy to be pointed in the right direction :slight_smile:

In the MnM there’s a SID arpeggiator mode that has one great feature - it activates the arp only if there are more than one note on a given step.

I’m trying to achieve trills/flams when using the A4 to control external CV synths, and would think that the arp should be ideal for this.

Alas, the ARP mode is not p-lockable on the A4, and despite the number og interesting ARP modes, there’s no SID mode. So I’m looking for a workaround to achieve trills only on selected steps.

I did get it to work somehow using the LENGTH parameter. LENGTH is supposed set the length of the arpeggiated notes, but it seems this parameter is ignored with multiple notes on a given step (is this a bug?).
Thus using only one note on a given step I can use LENGTH to “delay” the arp repeat infinitely whenever there’s only one note on a step. However, this involves setting LENGTH to INFINITE, and I won’t be able to p-lock gate time pr step which is a bummer.

Here’s an example. You can hear the single (non-repeated) notes are sustained until the next note.
It would be great if I could select arp on/off pr step and still have control over gate length.

Any ideas?

For the notes you don’t want to arp, you could set note length value to 1 or less and Plock the release time to be longer. Then on the trig you want to arp, extend the note length to the desired trig count.

IIRC I need to have the arp length set to infinite to avoid arp retrigging.

Or, by note length, are you referring to a different parameter from the arp length parameter? How will this aprameter interact with the arp length parameter? I’m not too familiar with the A4 yet…

EDIT - the arp length parameter really should not affect the gate time at all, should it? It’s there to control the number of arp note repeats, right?

Now I understand even less :confused: I need to spend some more time on this issue, obviously…

There are 2 different length parameters, one in the ARP section, one in the NOTE section.
As mentioned previously, in order for the arp to trigger, the NOTE length must be sufficiently long. So, by setting the NOTE length suitably short, and then playing with the envelope for that step, you could achieve what you’re looking for.
Cheers !

To be a bit more “academic”, the NOTE length sets the length of your arp, whereas the ARP length sets the length of the notes WITHIN the arp.
Hope this makes sense :slight_smile:


Superb, thank you very much! :+1: