Analog Rytm Mk 1 causing 2015 MBP to restart

Hi all,

Need some help please! I have an Analog Rytm Mk 1 (couple of years old, bought brand new) that, this week, has started to make my 2015 MBP to restart - I get a black screen stating ‘your computer has restarted because of a problem’ or something to that effect written in various languages (I’m sure you know the screen I’m talking about).

Here’s my set up:

Minilogue, Minibrute, Minitaur, Hydrasynth, Digitakt, and Rytm go into Elektron USB hub then to right hand side USB of MBP.

MBP is 2015 13" model, 16GB RAM, 1tb SSD hard drive, with no issues running OS 10.12.6 - still works like a dream.

Here’s what’s happening:

When Rytm is powered on whilst connected to USB - computer restarts
If Rytm is already powered on and then USB is inserted to computer - computer restarts

Here’s what I’ve done to source problem:

  1. Connected each synth individually directly to MBP in both powered off (and then powered on) and powered on and find no issue except with Rytm
  2. When Rytm appeared to be problem - checked Rytm using three different USB cables to check it wasn’t the cable and same problems described above happened
  3. Tried all synths plugged into Elektron USB Hub EXCLUDING Rytm and no issue was found.

So I’ve got two questions:

  1. Has anyone else had this problem? What did you do? (Going to report this to Elektron at the same time but figured I would check here too)

For info: Rytm is running OS 1.50 and, not sure if it’s necessary, but an F appears in the bottom left of the display when the machine boots up. Don’t know what that means but posting in case it’s useful.

  1. Sorry for this one, sure I can find it somewhere but in a bit of a panic: I’ve never backed up my Rytm and now obviously need to do so ahead of any potential factory resets - could someone walk me through what I need to do to maintain integrity of projects/patterns/kits/settings etc? Or link me to a manual/guide/forum post that does this? (I’ve accidentally wiped all my projects before and promised myself I wouldn’t let that happen again… but obviously did nothing about it!).

Any thoughts or ideas/tips/advice on either question will be greatly appreciated! Keen not to lose my work/destroy my computer or Rytm


And, for clarity, I’ve checked all synths and cables using the left side USB port on the MBP as well - same issue with Rytm causing the MBP to restart

Not gonna lie. I thought MBP 2015 was some synth I wasn’t aware of. :man_facepalming:

Rytm is in midi usd mode or Overbridge? Is overbridge app is running?
Can you update your RYTM to 1.60A on a different machine?

Ha! :slight_smile:

Rytm is in Overbridge mode. Overbridge as a plugin is not running on start up - that is to say, I turn on my devices and then load up Ableton and then Overbridge. However, Overbridge Engine appears in dock (? - where the clock/date etc is) at the top of my screen on start up.

I could, in theory, try to update to 1.60A from another laptop. I have a 2009 MBP that is still just about working so could give this a go.

The Rytm still works fine, just loaded up an Ableton project now and it plays and syncs fine. And weirdly, after I closed the project I restarted the Rytm to check if it happened again and there was no issue…

So Overbridge engine is running.

Yes, Overbridge Engine is running (and it runs on startup on my computer) and can see the Rytm. It also is functioning properly with audio over USB working as well as programme change messages all functioning properly etc

I have this problem with my MBP 2014 and AK. Used to connect to OverBridge fine, and then out of the blue starting doing exactly as you describe.

I went through all the actions you did, could not solve it.

I installed a clean version of macOS on an external drive (as a test), installed OverBridge and the problem was gone.

So it would seem that something on macOS gets in the wrong state. I don’t know if it was something else I installed, or what.

At least I know one possible way to fix it - start with a clean re-install of macOS. But I just haven’t felt up to the task of re-installing everything on my Mac. So for now I’m living without OB. If I want to record AK, I use audio interface.

Edit: I have AHeat, and that connects to OverBridge just fine. No problems, no crashes, no reboots.

Sorry to hear this! And yes, good shout about a clean install. Going to try and update the OS of the Rytm as well, see if this helps.

After posting the original message, I went to check the power supply of the Rytm and see if the Digitakt one would work with it - could have been a power issue. Found out the Digitakt power supply isn’t compatible with the Rytm so was unable to try. Anyway, in the process of getting ready and unplugging everything, and then replugging everything back in, I loaded an older project on my Rytm (had a thought about a corrupt file or something). I was able to load Ableton, play the older project, then I loaded the newer project, and there have been no crashes.

I don’t know what has changed, as I haven’t touched anything (except unplug and plug back in cables) and there have been no crashes. I have been turning the unit on and off and unplugging the USB and reconnecting it to test it and, so far, no crashes. Out at the moment so will test again later tonight when I’m home but the problem seems to have just disappeared.

I appreciate I am tempting fate by posting this but fingers crossed anyway…


MBP from 2015 (and 2014 as mine and as I am concerned) are NOT equal in terms of power deli Rey to USB.
Facing your laptop, you should always connect whatever is sucjing more watts and volts on the LEFT side USB.
Exactly the same happened to me with… Maschine Jam. A simple USB swap was enough to fix it :slight_smile:
Hope this helps.


1 Like

Ah, thank you! I didn’t know about this. And thank you for the link. Swapped everything round just now so keeping those fingers crossed there’s no more problems :slight_smile:

1 Like

Hey, got a reply from Elektron today. In short, they said they weren’t aware of this issue but that it sounded like a grounding issue. I appreciate you saying your issue went after you updated macOS so this may not be useful.

As my problem has gone away (hopefully) I don’t really have a solution but some things they mentioned to check:

Make sure device and computer are plugged into the same power outlet.

  1. Plug USB cable into computer
  2. Plug USB cable into ​Analog Rytm
  3. Power up ​Analog Rytm

Does the issue happen? And then the next thing they said would be to connect your device to a grounded mixer (if you have access to one) to see if you still have the same problem.


I find ARMK1 as very “delicate” in terms of USB connectivity. It’s losing overbridge connection pretty often in comparison to super stable Digitone.

Thanks for the feedback.

I am away from my equipment until Tuesday, but will give it a try then.

any news on this issue? I just tried overbridge in my macbook pro 2018 running mojave, with both rytm and overbridge updated and it kills my computer everytime…

Sorry for the slow reply! My problem seems to have gone away so can only assume the power cable came loose at one point and that this caused a grounding issue. Elektron seem really keen to investigate if the problem comes back though so I reckon you should get in contact with them if you haven’t already done so