Are Progran Change msgs sent when chaining patterns?

I have AR -> A4. AR is clock send, transport send, PC send. A4 is clock recv, transport recv, PC recv.

If I play pattern E1 and change to E2 on AR then A4 plays pattern E1 and changes to E2. If I create a chain E1->E2 on AR, A4 will change to E2 and then just stay on E2, never changing back to E1.

Both machines’ patterns are set to normal mode, 64 step, 1x

My hope was to build the chains (eventually song) up on the AR and have the A4 just follow along. Do I have to make corresponding chains (eventually songs) on both machines?

Many thanks in advance

PS searching has thrown up a few topics about this, but they’re on DT or they’re muddied by complex LEN=Inf type set ups. This is a very basic, minimal failing example (failing my expectations I mean, or is it a bug?)

They are not “muddied” by this. It’s crucial to the operation of the pattern change feature.

I suggest that you give precise settings for the two patterns in question or start a new project for experimenting with two patterns that use the simplest possible default pattern settings.

Have you set matching MIDI channel numbers on both AR and AF for the Program Change messages?

1 Like

Whilst I am grateful for your reply, you misread my post. I said that the other threads on this topic were muddied by exotic pattern settings. My example is on normal pattern setting, 64len *1. Yes program change chanels are explicit and matched. This is a minimal example.

I have! The only change is that they’re 64 step, not 16.

As I describe, the pattern does change if 1. I manually change them 2. the FIRST step of the chain, but not there after. AR keeps looping the chain, A4 remainds on step two

What about those settings in the 11.10.2 ADVANCED MODE section of the AR :

In this mode, the tracks of the pattern can be assigned individual lengths and scale. Select ADVANCED mode by navigating to the SCALE column using the [LEFT] arrow key. Select ADVANCED by using the [DOWN] arrow key. In ADVANCED mode, two columns exist, TRACK and MASTER.

The TRACK column sets the step length and time signature scale of the track. It works just like setting the pattern length and scale in NORMAL mode. The settings will only affect the active track. Press the [TRK] + [PADS] to select the track whose settings will be edited.

The MASTER column is only available in ADVANCED mode. Here the master length, the master change length and the general time signature of the pattern are set.

LEN controls the amount of steps the pattern will play before all tracks are restarted. An INF setting will make the tracks of the pattern loop infinitely, without ever being restarted. Note that this setting also affects for how long the active pattern will play before a chained pattern starts playing. This can be overridden by the CHNG parameter.

CHNG controls for how long the active pattern will play before a cued or chained pattern will begin
to play. This setting is important when for example LEN is set to INF. If no CHNG setting is made, the pattern will play infinitely, and the next pattern will thus not be cued. By default a cued pattern change happens at the end of the pattern (CHNG set to OFF).

MASTER SCALE is the rightmost setting. It sets the general time signature of the pattern.

But I’m in “normal” mode. Are you suggesting I use advance mode to try and hack the expected/desired behaviour some how?

NOTE: without chains, everything works EXACTLY as expected (except sometimes the A4 seems to “miss” the first 64th, and I have to do a quick stop-start, a whole different issue.)

I have a cheap ass midi cable, could it be as simple as that? Can I use usb from AR -> A4 for midi messages?

Oops, I missed that part.

Have you tried the other way : A4 > AR (Troubleshooting)

1 Like

Yeah, I’ll give that a go. Good call. Had to go to work.

EDIT: Yup works perfectly from A4 -> AR. OK, for now I will have to do that.

1 Like

Just did a quick test for you. I don’t have an A4, but I made a chain and sent it to my M:C.

It loops perfectly, with the M:C coming back to A1 in sync with the AR. Didn’t do anything special. Pattern modes are normal, autochannel on both is 14.

1 Like

Thanks, you mean you did an AR -> M:C chain? (EDIT: oh yeah, you did.)

Hmmm, I suspected the AR tbh. I guess now I have a Pisound I can maybe route the midi through that and dump all the messages. Do it both ways, and see what is up? Maybe? So maybe it is the A4 at fault with how it handles the messages from the AR.

Yeah, the AR seems to send the pattern chain correctly to the Cycles. So maybe it’s the A4.

My experience with coupling multiple Elektron devices is that when you change a pattern length on the master device, the slaved machine(s) tend to lag behind. One of my main gripes with using multiple Elektrons to jam. The only way I found to counter that, is switching manually on all devices playing.

1 Like

That A4 testing me again.

Huh, after about 20 minutes of jamming it happened the other way. A4 changed and AR missed a whole round before changing. I disable a chain, then made a change, and that is when it happened. OK, weekend project is to learn how to capture and dump midi messages between these devices. My only concern is that the messages are fine, and the device responses are the issue. I’ve been programming networked applications (distributed databases) for many years, and what I am seeing, my intuition tells me, is a problem with buffers.

1 Like

This is exactly my experience s wel… with DT / DN combo and also AR/A4. What is that Elektron? This is a super fundamental thing. Syncing multiple Elektron devices. It’s an unpredictable experience right now.