Arturia Keystep MIDI issues into Ableton, any help appreciated

So I bought a 2nd hand Keystep today, which works, it lights up and works fine straight into A4. But into Ableton it’s a different story, it lights up but no MIDI sent to Ableton.

I’ve tried holding Oct- with Oct+ while plugging in power to factory reset, I’ve tried all different sync options on the back, tried choosing Beatstep in Ableton MIDI Preferences, tried connecting to Midi Control Centre where it doesn’t show up, tried both USB ports on my Macbook Pro, tried restarting computer, tried quitting programs then plugging in and the other way around. Any suggestions?

I’ve tried these instructions as well: Keystep Mac firmware upgrade solution

Running MacOS 10.13.6, latest Arturia Midi Control Centre. Bought the Keystep 2nd hand so unsure of it’s firmware.

The only thing I’ve seen online is that there’s different Micro USB Type-B cables where some won’t be able to send MIDI. And if so, what specifications am I looking for it to be able to send MIDI and not just power?

At this point I’m going mad so any suggestions would be appreciated, I’ll contact the seller to ask if he used this with a DAW before but it’s late right now.

Is it an Ableton thing or a MIDI thing is the first question. Have you tried something like this to see if MIDI is incoming? Web MIDI test page

Within Ableton have you set the input and armed the track?

1 Like

Midi from the Computer Keyboard is working fine, sadly I don’t have any other Midi controller to test with but it was working fine a month ago before I sold my last one.

I’ve set the input and armed the track in Ableton, it’s not receiving any Midi input on any channel, tried changing Midi channels on Keystep too. The Web MIDI test you sent didn’t show anything either…

Might be a lost cause, or that I have to get a Midi interface, which is a bit overdue either way.

Did you double check the dip switches?

1 Like

Yep, tried every combination. At the moment they’re at the USB configuration.

Try to reverse the dip switches. You might have set them wrong way around.

1 Like

Hopefully the one I sent you works! Maybe quickly try a couple of others - I just grabbed that quickly but can’t check it myself right now I’m afraid - don’t want to lead you astray!

Double check those dip switches and report back - I’m assuming it’s not showing up on your Mac? I forget where it would I feel like there’s a section of the Settings panel for MIDI controllers

1 Like

I don’t have Arturia but I did have some issues with my Launchkey Mini in the past so just sharing things to try:

there’s a tool called MIDI Monitor, it’s a standalone app and you can see if the MIDI registering on the mac.
If not, see the Audio MIDI Setup (open the Window > MIDI Studio) and check if the keyboard is even registering, if not, it could be that the cable or the USB on the keyboard is not working:

After that put the MIDI Monitor that should be included in Live on a MIDI channel and see if there’s any data

There’s also MIDI indicator in the top left corner:

If it’s not triggering any of these check Live Preferences to see if the keyboard is setup correctly, the Track checkboxes should be checked for the keyboard to get the midi:

1 Like

Installed MIDI Monitor, but it doesn’t show any incoming messages. I’ve tried deleting old MIDI drivers as well.

In the Audio MIDI Setup, the keyboard isn’t showing actually. I’ve tried reinstalling the Arturia MIDI Control Centre, from what I’ve understood the drivers should be included in there. Checked the MIDI Monitor M4L device too, it receives MIDI from the computer keyboard but not the Keystep.

Checked the Midi Preferences in Ableton as well, but it doesn’t show up at all. I’ll go and buy a cable and see if that helps at all!

yeah sounds like the keyboard is not connecting at all, could be cable, could be the usb connection on the keyboard, could be some setting on the keyboard I’m not aware of, try searching in the manual if there’s something about MIDI over usb or similar…

Bought a cable and damn, it was the cable haha. So weird since it got power from it, but issue solved! Thanks for all the help in troubleshooting man :pray:


glad to hear it worked out :slight_smile:

1 Like