Audio Dropouts


I was playing around with my new shiny Octa yesterday evening and was focussing on live sampling / resampling.

I had a Flex machine set up with a One Shot Record Trig on the first note and a Note Trig on the track.

When I armed the track the OT sampled the incoming signal and then played it back. However, quite a few times the audio dropped out when the Record Trig was triggered.

Wondering if I’m doing anything wrong, or if this is a limitation. It seemed to be a bit inconsistent in when it would do it (sometimes it did, sometimes it didn’t).

Cheers in advance!


Are you trying to set up OT to perform immediate playback of recorder buffer? I had no luck with this when I tried to preslice recorder buffer and use those slices immediately for playback — some slices were inaudible and this seemed to be random.
I came to conclusion that this is a limitation of OT (which seems to be logical since you cannot play back what is being written with zero latency, and OT tries to stay in sync all the time), but it would be nice if some solution to this exists :slight_smile:

Yeah I was, I seemed to get it working ok with slices weirdly enough but not single full samples.

Hmmmmm, so I’m wondering how (or even if) it’s possible to feed it audio from an external source whilst it’s playing - or will I always have to mute that track and then unmute it when the audio is captured.

Even if it just opened the monitor whilst it sampled and then switched from that to the sample at the end, then at least it wouldn’t be silence.

I can’t tell if I’m doing it wrong though as I’ve been watching a lot of YT videos and people seem to be resampling live like crazy and the OT is handling it.


This is indeed possible. You have to route external audio the way you like (DIR ot Thru machine method). Then you set up recorder 1 to capture audio input (say record 1 bar loop from AB) and place playback trig of its recoding on step 1. Then select scene 1 and set XDIR (if using DIR method) or XVOL (of Thru machine) at desired level. Set XVOL of track, which plays captured loop to 0. For scene 2 make the opposite — XDIR/XVOL to zero and XVOL of captured audio to desired level. Assign these scenes to crossfader and you’ll get smooth transition between sampled and live sound.

OK cool - I’ll give that a whirl. Thanks for the tip!

Hmmmm, just playing with this again now that I’m back home from work. It seems to be more of a bug… sometimes it will drop out and sometimes it won’t.

If I set a one shot trig in the recording set up and then move over to watching the waveform, sometimes it’ll draw in and play the audio and other times it’ll hang after a split second and wait until it’s looped round and then start playing.


So an Empty Reset seems to have fixed it - or at least I’ve just jammed the past few minutes and it’s not dropped the audio.

Hopefully it’ll never rear it’s head again… :confused:

Edit: It’s doing it again… Gutted

I‘m encountering the same. Did anyone find a solution to this?

Check things like rate and pitch on your flex playback, and also lfos if they target these. By default lfos target pitch, so make sure unused lfo depths are at zero…
What can happen is your playback settings can make it so your trying to play a part of a sample that hasn’t been recorded yet. If using a one-shot this will be apparent if on the recording pass the audio drops, but after that it plays back fine…

If this is the case for you, you don’t necessarily need to alter the settings to play fine on the recording pass, you can, or you can be OK with waiting for the second pass to get results not available in one pass…


Yep. Possible to have realtime playback with recordings, with Flex machines.

With internal SRC3 recordings, you need +1 microtiming on playback trig, or - 1 on rec trig.

I didn’t test it since ages, but :
Disable Timestretch for realtime playback with input AB, but you can use timestretch with microtiming. (Problem only when slaved maybe, but you can check this out).
You can pitch down, maybe with + microtiming.
You can pitch up with lfos, with certain lfo on start settings for playback.

It‘s a fresh new project so LFOs shouldn‘ t be the problem. The microtiming makes sense as far as I would encounter dropouts on full bars right?..but it happens in the middle of a bar and audio comes back at the beginning of the next iteration. Will try the microtiming hack anyway hoping that it works.

Thanks a lot for your support!

On a fresh project a recorder trig set to an input pair and a playback trig assigned to the buffer both placed on the same step with no microtiming adjustments will pass though audio continuously without glitching…
Might you be midi slaving?
Something else must be going on…:hushed:

Yep, the Octatrack is midi slave to AR via Midi thru an A4. Can this cause such problems?

Try it as master, if it works then that’s the issue and you can go back and see if changing cables, clock source, or even just the routing of the clock source might improve its operation as slave…


Will give it try. Thanks!


Yep. Master is better if possible. When slaved, timestretch doesn’t work well, and Pickup’s Overdub doesn’t work at all.

1 Like

Using Octatrack as Midi master did the trick! No drop outs aynmore. Thanks again.


Yup, adding a nudge of micro timing on either the rec trigger or play trigger is step 1.

Not playing a part of the sample that hasn’t yet been sampled is step 2 (ie: don’t jump forwards in time).

The final step is to make the OT the master clock as any other clock & jitter will likely throw the playback sync out and you end up in a situation as per step 2.