Can the Octatrack mkII record into audio tracks while in midi mode?

Hi folks!

I’m trying to capture my performances with as much control as I can before needing the DAW. I control my machines downstream of the octatrack, with a separate midi controller going into it.

Since they all generate audio routed back to the octatrack, I would like to find a way to record these. But if the OT is in MIDI mode, which it must be to control the machines, I can’t find a way to make use of the OT’s audio track recording/sampling.

Is it possible?

Edit: Also, is direct monitoring the Cue Outs possible?

Q1: If you use oneshot record trigs you can arm them as normal in MIDI mode with [track] + YES. Haven’t tested whether you can record with [track] + rec myself.

Q2: In the mixer you can see a crossfader on the left that looks like this: M–|--C
This controls your headphone mix of master and cue outputs. Use the level knob to bring it all the way over to C and your headphones will only output cue.

edit: You shouldn’t need to be in MIDI mode to have MIDI output. Is this because of your separate controller?


Apparently. He probably uses Auto Channel. If you use midi tracks channels instead, no need to be in midi mode to use external midi.

1 Like

thank you for this response.

q1: I found no issues using recorder trigs while in midi mode, so great – I can record my performances. :slight_smile:
But, I tested auto channel vs. track’s midi channel, and the OT only received midi when auto channel was on (ch.1), not when it was off. Maybe I tested it wrong, but I doubled checked all the channels were fine (I was only using channel 1, both for auto and track channel).

q2: I see that main/cue mix in the mixer, but I am not using headphones though, I’m using the stereo outs.
Actually, the cue output goes to an effect which then goes into the Digitakt input (monitor on), which in turn goes back into the OT. At the moment I can’t find a way to live monitor this effect. Only when a track on the OT has a sound assigned to it and plays can I then monitor the cue send/return.

I guess this is because I am direct monitoring the sounds, rather than monitoring any track of the OT.
…I just tried with a Thru machine, with the correct input set, but I can’t hear any sound from the Digitakt to the OT.

Apologies as I’m just getting back into the OT after months away from it.

With thru machines you need a trig on step 1 and press play to hear the sound. Trigging the thru machines is necessary for them to start passing through incoming audio.

1 Like

of course!

Thanks my friend

1 Like

You can use midi track channels with your controller in audio mode. No need for Auto Channel in that case.
Midi tracks channels have to be different from Audio tracks channels.

Controller in audio mode? Not sure I follow.

Midi track was different from auto channel because when I tested the midi channels auto channel was set to OFF.

Otherwise midi tracks can’t receive midi data.

OT can be in Audio mode to control the machines, if you use midi tracks channels instead of auto channel. How to say it differently?

We just have our wires crossed. Plus you quoted something from my OP, which demonstrated my original thinking, which is no longer relevant since our discussion is now further along.

I understand you’re saying to use midi track channels / not auto channel to transmit midi through the OT even if in audio mode. I just couldn’t get that to work on my end.

“midi track channels different from audio tracks channels” – do you mean any channel other than 1-8, because that’s the only “audio channels” I could make sense of, being that the tracks are numbered 1-8. Didn’t know you could specify audio “channels”, in the same way you would midi channels.

Thanks for trying with me.

1 Like

By audio track channel @sezare56 means a MIDI channel assigned to an audio track.

Each audio track can have a MIDI channel assigned to it. A MIDI channel assigned to an audio track cannot be used by a midi track simultaneously, because the audio track will not let the data pass through to the midi track.

From the manual:


If an audio track and a MIDI track share the same MIDI channel, the MIDI track will block the audio track from sending out data while the audio track will block the MIDI track from receiving data. In the PROJECT menu you can see which MIDI channels are assigned to which audio tracks. Read more in the section “MIDI” on page 41.


Maybe you couldn’t because of audio tracks channels 1-8. So it is possible to use audio mode and external midi. If you prefer to use midi mode only, no problem, but it is limited.

1 Like

Ok, I got it working but not without being in midi mode.

Even if I turn off the audio midi track channels, with auto channel OFF it only transmits in channel 1. Now, when I turn ON auto channel (set to ch.1), I can go into midi mode and select different midi tracks set to different channels and they transmit on the correct channel. But if I turn off midi mode, I hear nothing (because auto channel is ON)

1 Like

Ok that’s normal, if you can send only 1 channel with your controller and need more channels for external gear…

1 Like

Ok, thanks.

I thought there would be a way to re-route incoming channel 1 from an external controller via the Octatrack through assigning track channels of your choosing. Otherwise how do people control long chains of hardware with midi thrus via a single keyboard controller?

From my knowledge, you can’t set a single controller to ‘output all channels’.

Edit: there is obviously a way to re-route, but only in midi mode.

Edit2: I think I went down a red herring trail with this ‘midi mode’ thing, it’s not that important… From yours and others feedback I have a better way of controlling my downstream hardware than I did before so thank you. I’m in the 60% success/40% pulling my hair out stage.

1 Like

You can change channel, split the keyboard, use a midi patch bay, a midi processor…


Not sure if the original question got answered but, yes you can record to the audio buffers while remaining on the midi screen. You even get the little recording ‘+’ to show you it’s happening.

If you’re on a mk1 and you need to use the MIDI button to start an internal recording, you just have to long-press that button (along with track button) to stop the OT toggling out of midi mode.


mkii, and thanks for confirming!

Cool. Works with rec buttons as well as the rec trigs method @Merv responded with in post 2! (Sorry, read that but forgot after reading all the midi control stuff!)

1 Like

Maybe I missed something, but I can’t see “+” in midi mode. But recording actions work.
If you hold the track button, no need for MIDI button long press (MKI).

1 Like