Digitakt 1.11 : Bug reports

I was going to try switching off Overhub next ( i am glad you sorted it) but I tried it thru C6 instead and it worked. Weired behaviour indeed.

So far i have observed (not sure if by design or bugs)

  • Randomise doesn’t work for Trig - i am guessing this is by design as it doesn’t message randomise
  • Randomise doesn’t work for Mixer page - Message indicates randomise but no change
  • Randomise works for compressor but the reset [LFO] + [NO] doesn’t reset comp parameters despite message stating reload.

how are you managing to do this? it’s not possible to ‘hold’ the comp page and tap Yes to randomise here - it will just randomise the LFO page
[EDIT] ah ok, you need to hold Func+LFO+Yes…
yea same here, the values don’t return to previous state despite what the message says.

1 Like

Press [FUNC] and [LFO] for the master page. Cycle to get to the Comp page by tapping LFO with FUNC and then keep LFO pressed down when on Comp page. Then with LFO held press [YES]

1 Like

It’s the same with Delay and Reveb pages too - will randomise but wont return to previous states

1 Like

Yes try ill register a ticket

Help please!! After updating mute function stopped working. Cant mute/unmute any trigger anymore, not even on mute mode.
Any suggestions?

Anybody on here having midi issues after update 1.11? I am trying to assign synth patches to the sequencer which I could do before with the midi bank and program settings, now there is a new option subbank which is a great idea but now my synth’s are not responding to program changes. upset and moody now! doh.

1 Like

Give a specific example of what you are trying to do and what is actually occurring.

I am using the digitakt for sequencing and drums, working on a chain able song. So say we want pattern 11 in the chain to have our roland system 1 start playing on patch 8 on midi channel 1, the digitakt sending the system 1 channel, program and bank changes. I also have my P12 hookup as well on midi channel 8, also requiring program and bank changes. So before updated I could come into the studio turn on the synths, hit play and both synths would go straight to the right patches and banks. I now can not achieve this.

What settings do you have on the Digitakt, and what is actually happening?

whats happening is when the pattern starts the system 1 doesn’t change to the right patch that I have assigned in the midi SRC page.
setting wise I have the prog ch send and receive on, clock send on
ports - midi in and out-on, output ch-auto channel, parm out cc,
channels page, auto channel 10, prog chg out and in-auto,

also working on a track that was on here before updating if that makes any difference.

What values for BANK, SBNK, and PROG have you set for your pattern on the relevant MIDI sequencer track?

BANK is set to 2
SBNK tried to set this at 2 as well swapping the both around.
PROG is set to 8
If I turn prog button it lights up the patches on either synth no problem but then when starting the sequencer it does nothing, so say the next pattern has a different patch assigned on the PROG it doesn’t recognise it and stays the same even when its set to the right number.

I got it to work a couple of time by trying some trigless trigs to change the PROG before the next sequence but only worked randomly and can’t really duplicate. I am pretty sure this is a bug and its driving me mad.

Roland’s documentation is not good but it is likely that the BANK and SBNK settings are not necessary. Because the System-1 only has 64 program memories, you can probably set those using only values of PROG from 1 to 64. Edit to correct: it seems my guess is wrong; I read on the web that you need to use SBNK in the range from 1 to 8 and then PROG in the range 1 to 8 to access the 64 locations. BANK should have no effect.

The P12 should not respond to BANK, only to SBNK and only in the range from 1 to 4.

Try these values in case they work. If not, we can investigate further.

1 Like

Thanks for getting back. What a late night. At the end of the night around 3am I open a new project and it worked. I then tried opening some old projects and it worked most of the time with a few glitches depending on what patterns I chained. Weird. But basically works. Yep Roland doc’s are a bit thin. Last night I got the SBNK to work which is cool because before it would only select 1-8 patches but now I can select all of them! sweet. I still think there is a bug in there especially in older projects but hopefully this will get sorted as I couldn’t get it to respond perfectly with all projects. Thanks again.

1 Like

Yes, sadly mee too. Just updated my DT to 1.21

I am encountering the same problem. I popped on the forum to see whether I was alone in that. Guess not!