Digitakt midi loop problem with external gear

Hello, I’m chasing some problems when sequencing other gear with digi, but also bringing midi back in from those devices. Basically I want to be able to sequence a Nord 3p and a Minilogue, but also be able to play the keys/pads of both of them into the digitakt sequencer. So far it works fine in one direction (digi sending midi out) but when I send a note from either of the other devices, I get a duplicate note ‘echo’ from the digi which causes strange behavior. My midi interface is capable of filtering, but I don’t know how to target only the doubled notes, and still allow the digi to be able to send notes on key presses/trigs. I assume other people must have worked out midi in both directions, curious how. Thanks!

You don’t give many details of your setup, but I would suggest:

  • on the Minilogue, setting Local SW to “Off” in the Global Edit mode;
  • on the Nord Drum 3P, setting Local Control to “Off” in the Global settings.

Thanks for the suggestion, I’ve actually tried that and it doesn’t seem to make a difference. I still get 4 midi events when I hit a key/pad. 2 note ons, one from synth and one from digi, and then 2 offs. As an example of a conflict, when I play a sequence on the minilogue it drops random notes, I suspect the doubles are canceling each other out or something.

In that case, it might be helpful for you to provide a detailed description of your system and the MIDI settings on each connected instrument.

Sure, here goes. Normally everything gets routed through an iConnectivity mioXM, but I’ve take this out of the equation and just hooked each synth up to digitakt alone, via din midi in and out to narrow down the issue. So in the simplest cases where problems occurs:

Setup 1
-Digitakt midi out to Minilogue in
-Minilogue out to Digitakt in
-Minilogue midi set to send and recieve on channel 15
-Digitakt midi track ‘G’ set to send and receive on channel 15
-Digitakt auto channel set to ‘off’
-Digitakt ‘Output Channel’ set to Auto (I’ve also tried ‘Track Channel’ but I get even worse issues)

Setup 2
-Digitakt midi out to Nord 3p
-Nord 3p midi out to Digitakt using Retrokits RK002 cable
-RK002 intercepts the notes put out by the Nord on its global channel, and splits them out to midi channels 9-14
-Digitakt midi tracks A-F set to send and receive on channels 9-14
-Nord pads set to listen on channels 9-14
-Digitakt auto channel set to ‘off’
-Digitakt ‘Output Channel’ set to Auto (I’ve also tried ‘Track Channel’ but I get even worse issues)

Is this occurring with Local SW set to “Off” on the Minilogue?

Where does the “duplicate note ‘echo’” emanate from? Is it another note at the same or a different pitch on the Minilogue, or does it come from the DT? What do you mean by “causes strange behavior”?

Have you set any other channels on the DT (in either the Settings menus or the other MIDI tracks) to be 15?

-yes happens even with local sw set to off
-the duplicate note and note off comes from the digitakt and is the same note value as the key being pressed
-nothing else is set to channel 15
-an example of strange behavior is when minilogue starts playing a sequence, notes somewhat randomly drop out, and the oscilloscope shows a kind of flat line all the time instead of the normal waveform
-I also tried enabling the digitakt auto channel and setting it to 15 as well but then I get audible glitching/repeating noises when sending a note to the minilogue

This! I have the exact same problem with „echo notes“ with my Pro 3 (with Local Off).

Has anybody fixed this?

No luck here