Have the MIDI track play non-diatonic notes when set to a key

So when you set a KEY on a MIDI track (found in the MIDI arp setup) the track auto-transposes all notes to the key signature you set.
Is there any way to override this? Having it set to a key-signature is great for most part, but completely locking all notes all the time is boring. Being able to use non-diatonic passing notes or modulate to a neighboring key-signature for a chord on occasion makes music a lot more interesting.
I’ve tried setting “transpose” up or down a semitone when i want to modulate a note or chord at a specific time in the sequence, but whatever KEY is set to has the last say what notes are played.
Anyone relate to the problem? Any workarounds other than to use a different MIDI-track (with KEY set to OFF) for modulations?

I don’t know of a convenient way around it. Tbh I only ever use the function if I want to use an LFO for random sequences but in a scale.

You can set the arp on OFF for a given note.

Even if the arp isn’t activated all notes are locked to what you set KEY too.

Since the KEY setting isn’t linked to the arpeggiator, it would make more sense to have the KEY setting on the MIDI note setup page, and not the arp setup page.

I thought they were connected. No more space on the SRC page though.
What would make sense for me is to have more than one scale, at least to be able to define your own (including chromatic) and to connect it to the Arp.