Issues with keystep>RK-002 cable>digitakt

Hi all,

My digitakt receives midi info fine from a keystep (normal midi cable).
It works with RK-002 polyphonic cable (RK-002 cable in midi loop back - out to in)
It DOES NOT work with keystep > RK-002 > digitakt. No midi received at all.

What might be explaining this weirdness? Somehow the keystep and RK-002 don’t like each other? I know the keystep doesn’t transmit sysex… but that shouldn’t be an issue, right?

I’ve also tried channging port setting from ‘track channel’ to ‘auto’ channel. No change.

Any ideas? thanks

I have a keystep playing my Digitakt polyphonically through an RK002 cable, so I can confirm that it works.
I am using the MOD firmware. It’s worth checking MIDI channels on the cable setup page, Digitakt and Keystep to make sure everything matches.
@DaveMech has some great YouTube videos on this very setup that explain step by step how to get everything working. They certainly helped me out after a bit of head scratching trying to get it to work (cheers Dave!).


Rk002 needs to be powered over midi. Digitakt does supply power over midi ,maybe the keystep not.
I suggest you to check if it works with other keyboards or soundcards.

The default channel for rk002 with Duy firmware is channel 9 ,so you could start setting the keystep on channel 9 ,otherwise try every channel of your keystep

The keystep sadly doesn’t support midi power.
You’d need something like the rk-005 to fix this.

Thanks for the kind words @DampSquid!

1 Like

thanks guys.

If you’re talking about downloading firmware etc., then yes, I have already done this, via the digitakt (which has midi power) and a midi interface.

I have set Track A to midi ch. 9, and the 4 polymux notes on track 1-4 worked!

However, I simply cannot get my other external synths to respond as well. I have changed them to receive on midi 9, I have the auto channel to 9, etc., but still only half a solution.

I can survive with this, but it would be nice to switch easily between internal polymux channels and external synths easily, without having to change cables :frowning:

The Keystep does pass MIDI power as long as you’re feeding it enough to start with. Mine works fine with the RK002 when the Keystep is powered from a powered USB hub or direct from my MBP.
I think a problem could arise if the keystep is powered from a battery or mobile device, then it may not be able to draw enough current to power the keystep plus the RK002.


Interesting. Thanks for correcting me :slight_smile: Have Arturia updated this at some point? I remember it wasn’t supported a year ago.

I’m not sure if they updated the hardware. I certainly didn’t hear anything about it if they did. Not sure how they could change this through a software update though.

Mine is new. I picked up one of the new black ones a few weeks ago (after my poor old SL mk2 started flaking out on me :sleepy:).
I know it definitely doesn’t pass sysex so can’t be used to change the firmware on the RK002 but it’s ok for power.

Aah maybe I was confused then. It couldn’t be used to update. That’s it :slight_smile:

Hi @soundgoonie , my setup is very similar as follows.
I am using the MOD firmware with Polymux rather than the Euclidean one.

I have the Keystep connected to the MIDI in on the Digitakt with the RK002 and a synth connected to the MIDI thru on the Digitakt.
I can then play the Digitakt polyphonically on channel 1 and quickly change to channel 9 on the Keystep to play the synth. It works great - just check none of your required channels are filtered out on the cable firmware setup page.
I’ve not tried using MIDI loopback with the RK002 so can’t help with that.


Interesting. I must be doing something wrong then. I’ll have to go back and re-flash the firmware and check the midi settings.


Hello, what midi interface do you use to change firmware? I tried with digitakt and with Akai MPD226 but both tell me “inquiry failed”

1 Like

I stumbled upon this message just now (bit late) but the ‘problem’ is the loopback mode of the RK002/DT firmware. by default is set to loopback mode so the DT does not choke in it’s own midi messages when you connect the midi out to the midi in. this does also mean that if you connect the RK002 to a keystep out instead of the DT out, it will block incoming midi from that too. You need to disable the loopback mode in the RK002/DT firmware at the DUY Exchange Portal


Hey @grit thanks for showing up here.

If I wanted to get the RK-002, connect it from a midi keyboard and play the Digitakt as a poly synth - and let’s say that’s all I care about in regards to the RK-002, the Digitakt polysynth feature - which firmware should I order with the RK-002 then?

I don’t have a midi interface to update the firmware, so I’d want it to work out of the box.

We could put the /MOD firmware on it with 8 channels polymux already activated, responding to MIDI channel 1 (which you should use to send out on your keyboard). It would probably be easiest to get started on. You’d need the DT channels 1-8 set to +/- the same voice and responding to midi channel 1-8


Very cool, thanks @grit

So if I specify this in my order, you can set it up before you ship it? And once I have it, I’ll just take it from there. Sounds ok? Thanks.

Yes sure, if you put it in the note we’ll preset it accordingly, I must say though - The RK002 being reprogrammable it would be handy to have a usb interface, it offers a lot more possibilities.


Yes, you’re probably right. Maybe I should just bite the bullet and solve the issue that’s on me.

I’ve just picked up an RK002 cable, but it’s formatted for the Volca Sample … any idea on how to update the firmware for Digitakt? I’ve tried via the Retrokits site, but can’t find a Digitakt flavour of the firmware there


1 Like