Loops not not seamless

A couple of things which I’m sure will be easily addressed.

I’ve tried a few search strings and nothing is coming up that answers my questions.

Loops-pre made/purchased:

I’m finding that loops of any bar size, aren’t ‘seamless’ and there’s an audible glitch at the loop points. This is most noticeable with kick loops.
I assumed it was the loops themselves, however everyone I’ve popped into ableton and lopped has been ‘seamless’ upon play back in ableton.

I’ve changed them to loop mode on, and beat for stretching, which hasnt made any difference.
Also, some seem to start off OK, but after few bars I can hear the loop point. Any ideas?

Loops-transition trick:

Much the same as above in that I’m recording a loop in a flex machine, using the main out as my source, with QPL set to 64 (as I’m recording a 64 step loop) and again there’s either an audible loop point or it sounds slightly out of time. I have nothing set on the SRC page, or amp settings and no fx are active on the recording track. Any ideas?

Usual caveat of I expect this to be user error.


1 Like

Might just have to tweak the attack a bit. I think ableton has some sort of auto-fade on audio clips which will automatically make the loops more seamless.


OK that’s a good idea.
A smidgen of attack may just resolve it.

I was thinking it was a setting in the samples menu I was missing.

I’m new to the OT, and I’m currently trying to work my way through a similar problem. I’m having troubles with getting a clickless/popless transition from stereo samples I live recorded into a flex machine.

Here’s a link that might be helpful.

A couple things I’ve gathered.

  1. If using stereo loops, change view of waveform in audio edit menu to see both L and R waveforms. You can then function snap to zero crossing points for both channels, and trim the loop at those points.

This didn’t work for me, but my sample is quite dynamic. So YMMV.

  1. Adjusting Fade in and Fade out on the loop in the audio edit menu will take away the pop, but it will also produce a noticeable volume fade (even at minimal settings). So practically this didn’t work for me either.

  2. I haven’t tried using Pickup Machines and the Fin and Fout function there, as described in the above link.

Let me know if you get the chance to do this and if it works. Would be much appreciated.


Try it. Fin set to 0 or min, Fout set to min.
With Pickups, in Overdub mode, Fout is added after the end of the loop > crossfade at the beginning with overdub.
With Flex, Fout is applyed before the end of the loop.


Is the OT the MIDI master? I’ve never been able to get seamless loops consistently with the OT slaved to a DAW, MIDI clock from a USB MIDI interface is just too unstable.


Oh ok. It’s slaved to ableton, and to be honest I’ve had no issues however, this could be a very good explanation. I shall test later. Thanks.

1 Like

Yep. OT master clock, otherwise a loop with the perfect bpm is like a lottery. :content:

1 Like

Cool. I will give it a whirl later.

If I’m receiving clock from other hardware (tr8s in this example), would it be a similar situation, or is this just because ableton is notorious for being a little out of sync?

Try, but I think it will be similar. A seamless loop is sample accurate. Even very slight jitter is bad. For tests you can record at 120 bpm, and check is the recording number of samples is a multiple of 44100 (88200 for 1 bar).


Well, it does seem to have been ableton in this case. I’m yet to test it with other hardware, however I suspect it’ll be a similar situation.

1 Like

The clock jitter from other hardware will probably be an order of magnitude less than the jitter from a DAW, you have a much better chance of that working. Can’t say I remember ever trying it myself, but a solid hardware clock will probably have around half a millisecond of jitter (which is around what the OT itself has). MIDI clock coming from a DAW via a USB MIDI interace can easily have 5ms-10ms of jitter or more.

I’ve had really good results using an Expert Sleepers USAMO when I need to get accurate MIDI timing froma DAW but I haven’t actually had a reason to use it with the OT yet, since I’m usually doing something completely OTB when I use the OT.

Elektron used to have their own proprietary system for getting more accurate MIDI to and from a DAW but I’m pretty sure they quietly took the interface hardware off the market a few years ago.

But yeah, using the OT as the master is the best option.

1 Like

I will do some tests when my Pyramid will have arrived. I had the Digitone as a master for a while (because it has BPM per pattern) and didn’t notice any issues with the OT being slave despite clock being sent over USB to the iCM4+ where the midi flow was filtered, merged and then forwarded over DIN midi to the OT. Both the DN and the iCM4+ seemed solid performers, timing was perfect. But I didn’t check if the OT was sample-accurate when recording, which I would have done if I had noticed anything and I surely would have: I’m quite obsessed over such things and am able to waste hours of my time doing tests and analysing stuff, checking waveforms and counting bits and bytes, instead of making music :frowning:

1 Like

I used to be obsessed, but with OT master clock I don’t have to. :content:

A bit risky for me, especially with internal resampling. For example, slice grid can’t be perfect is the recording isn’t, a loop with slight tempo difference can be out of sync after a while if triggered once…
You don’t have to check with OT master.

If the sample is triggered regularly, I guess it can be ok slaved.

TBH, I never use regular loops, I use trigged recordings all the time. Sometimes I even wonder what loops are for when you have an Elektron sequencer… I must be a bit stupid, because it seems such a big deal for everyone… I use looping on waveforms when doing sounddesign. Or the occasional special effect. I got the OT primarily because of numerous sync issues with guitar loopers, so I went for trigged repeats instead of loops since day one. I get the point for slice accuracy however, obviously that’s an important factor.


I see your point, I used loopers, and my recordings are trigged. Glad if it works well for you with OT slaved. :wink:
But if we are talking about seamless loops…:content:

I oftenly use loops on with slices, it can be used in a granular way with LENgth.
You can also use it for incoming signal, record 1 step, divide it with LENght, and you have a waveform while playing. It depends on tempo, so for me it’s another reason to have it perfect.
Unfortunately OT tempo setting is not precise at all. I’d like to be able to set 103.125 Bpm, which corresponds to A440 Hz. :meh:

Sometimes I’ll use a flex machine playing a record buffer in real time rather than a thru machine, and in that scenario any clock jitter means you get clicks and stuff whenever the sequencer passes the record trig, but other than that I don’t really use loops that much either.

EDIT: since the aux send trick works that way, clock jitter will make that click, too, I’ve had that happen before.