MIDI Output from DAW to Analog 4 Sequencer

Hi All,

I’m trying to record notes into my Analog 4 using a USB Midi keyboard and Ableton. I can ‘play’ the Analog 4 just fine with the controller, but can’t seem to record notes in either live record mode or by holding down a trigger and pressing notes on the controller. Since my controller is USB only, I can’t connect it directly to the Analog 4. I have note send info activated in Ableton and set up the Analog 4 itself correctly (receiving notes, correct channels, etc.). I’m a Pro Tools guy so I could just be screwing up the Ableton settings… oh for the day when Elektron and Pro Tools become friends :confused:

I stand to be corrected but I think the Elektron sequencers only record from their own buttons. The way to go would be to record the midi notes into ableton then sequence the A4 over midi. Or you could programme the sequence into the A4 and clock it from ableton over midi.

You can record to the Elektron sequencers via external midi, I do it by accident all the time by leaving record on while playing midi from my DAW or from my Octatrack. check out your A4’s midi setup ,maybe its set to midi-in not USB+Midi-in in the midi settings menu

1 Like

My bad! It’s not something I’ve tried yet. Too busy noodling on the boxes themselves!

Interesting. I wonder if there is a distinction between trying to record on the A4 sequencer using midi that has already been recorded into a DAW/Octa vs. live input from a keyboard. Seems like the auto chan setting is the common issue with a keyboard directly plugged into the A4’s midi port, but I set that up correctly. Will fool around some more when I get home and hope I get lucky :stuck_out_tongue:

The A4 can even live record via MIDI on all its 4 tracks at once (if wanted):

From the manual: LIVE REC ON TRACK CHANNEL when the box is ticked, active LIVE RECORDING will record incoming MIDI notes on each of the specified track channels (see below). When unticked, LIVE RECORDING will not (but still record on the currently active track via the auto channel).

You just need to get the settings right (and the MIDI routing in the DAW, of course).


I’m fairly sure grid recording mode (i.e. holding down a step and playing notes) only works if you’re sending data on the active channel (9 by default).

Still no luck. On Ableton, I created a MIDI channel with my controller as the input on Channel 9. Also manually set my MIDI channel to 9 on the controller. Selected the Analog 4 as the output and 9-Analog Four as the output channel.

Separately, I have an audio channel for the A4 and I can record live audio into Ableton from the A4 using my midi controller just fine.

But the sequencer still doesn’t detect any notes I’m playing in live or grid recording. Tried it while Ableton is stopped, playing, and recording. Also tried using channel 1 instead of 9, changing the appropriate ‘LIVE REC ON TRACK CHANNEL’ option.

scratching head

Are you 100% sure Ableton is sending MIDI data on the right channel? Easiest way is to change the active track on the A4: if A4 now plays sounds from the new track, it’s receiving data on the active channel.

Another way to check is to open the sound browser. Sending notes on channels 1-4 will still play the sounds on those tracks, but sending on the active channel will use the highlighted sound in the browser.

1 Like


Here’s what I’ve done. If I change the selected output channel (the drop down menu you can see now) to Channels 1-4, it changes the sound to appropriately match the four tracks on the A4. Similarly, I can change the Keystation input channel from 9 (for the active channel) to 1-4 for direct recording and it once again plays the correct track sound.

So it would appear that Ableton is sending MIDI data on the right channel and I’ve set up the A4 according to the manual (seems as though this is working as well since I can ‘play’ the A4’s individual tracks depending on the MIDI output channel I select, etc.

Buuuuuuut the sequencer still refuses to detect anything that I play. Also tried recording MIDI notes, then playing it back into the sequencer rather than recording live. If you solve this for me, I owe you a beer ilmai :smiley:

Are you using overbridge?

Yeah, using the Ableton plug-in and have the standalone 2.0 Overbridge app configured.

This may sound like a lesson in the suction of eggs, however…

And you’re selecting the a4 ob device from the midi drop down in ableton? And then the track (1234) from the drop down below that?

Yep that’s the dropdown box in the image I uploaded, I believe. MIDI out is going to the device 1-Analog Four, MIDI channel can be set to 1-4 and the correct track on the A4 plays. Just doesn’t record into its sequencer.

I’m not using Overbridge and it works perfectly through Cantabile. Maybe try without Overbridge? I’m running out of ideas here :smiley:

I am having the same problem. I can trigger to play the A4 or the DT from Ableton, but I can get it to live record the notes.

I am using latest Overbridge and up-to-date firmwares.

Could anyone else make the live recording work via Overbridge?

Same her… Did somebody figure it out ?

1 Like

You have to send the midi to the midi output destination from the midi setup in ableton…

you can’t record midi Into the A4 through the overbridge plugin


That did the trick ! Thanks DanJamesAUS.

1 Like

Try an external Audio Device as output tool, instead of the track output. For some reason it worked…