Midi problem - Avoiding recording p-locks received as MIDI CC when performing

EDIT: This does not only apply to my specific use case of “midi loopback”. It also applies to any setup where OT receives Midi CC from another device.

“ setting a Scene p-lock automatically while “performing”, just because there’s a stream of Midi CC incoming, essentially feels like walking into a mine field. Imagine you need to assign another scene to, let’s say, Scene B while performing “live”. The moment you hold that button, it’ll set a p-lock for the currently active scene, most probably without you ever realizing (since you may not even be on that particular “page” where the Midi CC target parameter sits at)”

Hello,

I used to do a trick on my DT to fake sidechain compression with full control of which track would be effected and how much, and it went like this:

  • Connect midi out to midi in
  • On each midi track, setup an LFO assigned CC controlling the AMP parameter, trig mode ONE, inverted EXP curve (minus depth adjusted to your liking)
  • Enter steps that would “duck” the targeted audio track (4 to the floor easy)
  • Have full control over which audio track is ducked how much, and how fast (depending on the LFO depth and speed on the midi track)
    And voila! every time a trig hits on the midi channel, it “ducked” the relevant audio channel assigned to it. The good part about this is, I could set it and forget, because if I enter step recording mode and try to p-lock something, even when the song is playing, the parameter “animated” by the LFO on the Midi track would not “record” a p-lock. Essentially, DT did not p-lock the CC data it receives over MIDI. I think unless I literally touch an encoder on the device, it doesn’t p-lock any parameter at all.

Now I’m trying to do the same trick on Octatrack, when the song is playing and whenever I try to p-lock a trig, or hell even p-lock a parameter to a scene, the parameter “animated” by the MIDI track (in this case AMP Vol) is p-locked and stays at the value when I release the trig/scene button off. This is super annoying! Am I missing a crucial piece of option buried in the midi settings? Is there a straightforward way for OT to avoid p-locking received MIDI CC?

I thought turning off “CC DIRECT CONNECT” under Control > Midi sequencer would resolve this but it didn’t. HELP!

1 Like

Yes. Should be optional. Only way is to stop incoming midi.

I already complained about it to an ex Elektron employee. Please write them :

feature-request@elektron.se

The fact that Digi’s behave differently is a plus to argue. No need to talk about midi loopback. This can happen with any external sequencer.

1 Like

You’re absolutely right. This is reproducable with Midi CC coming from any external gear (e.g: Digitakt sending CC to OT)

I actually created a support ticket with detailed reproduction steps, because this feels more like a bug rather than a feature.

1 Like

Imho it is a feature that can be annoying. Usefull if you want to record chords, plock CCs from a controller, a synth…

Another useful thing : plock randomized parameters from a CC random generator.

I would deem it a feature perhaps if it only happened in Live Recording mode, but it’s hardly a feature when it happens even in Step Recording mode, or even outside of it when holding Scene A or B button.

Then again, I would get away with it even if it could simply avoid recording “p-locks” for Scenes. I would turn Midi receive off (or unplug the midi cable) when “writing” a pattern as a workaround, but the fact that it can p-lock a parameter when playing live just by holding a scene button turns it into a BIG obstacle. :sweat_smile:

And please don’t take this the wrong way perhaps it’s my lack of knowledge but, how is the use case you mentioned (plock randomized parameters from a CC random generator) different from just looking away/closing your eyes and turning the encoder of the parameter you want to randomize? :upside_down_face:

1 Like

Some users use this feature ! At least one, can’t remember.

If I had to make a definitive choice, I’d prefer this off. An option seems more reasonable. :content:

1 Like

Or randomize pages

2 Likes

Okay, support replied back. They said p-locking pattern trigs via received MIDI-CC is intentional but they understand the concern and would include an “toggle” in options to turn it on/off into the development backlog and hopefully devs pick it up the next time they work on Octatrack. Frankly, the phrasing “the next time they work on Octatrack” felt like it would be months/years away (if it’s even picked up) since understandably, I think the newer devices (e.g: Syntakt) may have higher priority in the dev schedule.

I also highlighted I understand the use-case for setting pattern p-locks but I also explained how setting a Scene p-lock automatically while “performing”, just because there’s a stream of Midi CC incoming, essentially feels like walking into a mine field. Imagine you need to assign another scene to, let’s say, Scene B while performing “live”. The moment you hold that button, it’ll set a p-lock for the currently active scene, most probably without you ever realizing (since you may not even be on that particular “page” where the Midi CC target parameter sits at)

2 Likes

Hey, at least they said they would look at it! I think that’s a pretty good outcome. At least they didn’t say “oh that’s a 12 year old machine and we won’t change it”

2 Likes