MIDI to CV (eurorack) - MIDI settings from one bank/pattern affecting another - bug or human error?

Hey Elektronauts,

Is there anyone here who’s familiar with the eurorack module Hexinverter’s Mutant Brain (MIDI to CV) and also with the Octatrack?

I’m trying to get the two to behave together, and I think I’ve run into a bug on the Octatrack side almost instantly - on the MIDI side of the OT (or else I’m messing up a setting). I’m using the 4 top CV outs of the Mutant Brain to control MIDI CC, and what I’m finding is that:

Bank A pattern 1, will shadow its MIDI settings into the following bank (in this case Bank D, pattern 1). So I can’t properly adjust the second bank to have different MIDI settings… when I try, I can see that it’s reverting back to Bank A/patt 1’s settings instantly… it’s glitching between the two - which kinda defeats the point in using the OT as a MIDI sequencer. These are completely different banks/diff patterns… so they shouldn’t be influencing each other - right? Why would the previous pattern be influencing MIDI on the next? (in a different bank!)

Assigning the two different patterns to different parts doesn’t help either.

Is there a setting I’m missing?

But has anyone else come across this before? Is it a known bug or am I being an idiot?

I’m on OS version 1.40 of the OT.

Just been through the 1.40 bug report thread… and there’s nothing like this mentioned… so i guess it’s not a bug… hmmmmmmmm

EDIT; so as suggested, it seems placing a MIDI trig on the second pattern solves issue! up until that is done, the previous pattern’s MIDI CC positions are being transmitted, interfering with any changes on the new patterns (making the MIDI glitching effect I was talking about - which might be musically interesting, in certain situations!).

thank you:) apologies I hadn’t tried that sooner (i was just one trig from having it all work as expected!!). it’s the first time i’ve dug out the OT in a little bit, and i haven’t tried it with MIDI CC to CV before. always learning!!:slight_smile:

Have you tried saving the Parts in the second Bank before they’ve had a chance to “revert”?

bug or human error

I hope bugs will remain human errors rather than robot’s.:wink:

A usual part change problem : parts changes aren’t effective without trigs on concerned track (in some circumstances, maybe it doesn’t concern your settings).

Can you tell more about your midi settings, musical goals?

For me it’s a second level save state you’d want to reload after tweaking.

If you don’t save parts, last parts setttings are loaded, whatever banks are.
Parts settings are saved in bank files anyway, when you save the project or banks.

Maybe I’m wrong. Check it, I can’t.

This was my first thought too. But I’ve also seen Parts and BPM remain associated with a Pattern after deleting all the trigs, which can cause confusion when you re-use the pattern some weeks later :wink:

You’re probably right. You owned yours longer and practice more than me. I’ll check tomorrow when I’m less tired.

Or maybe I’ll check before bed…

I created a new project. Without entering [Rec] mode, so without any trigs, I set up the following:

  • Bank 1 Pattern 1 has Part 1; MIDI T1 uses ch1; MIDI T2 uses ch2
  • Bank 4 Pattern 1 has Part 1; MIDI T1 uses ch10; MIDI T2 uses ch11

I can change between B1P1 and B4P1 and see my MIDI ch assignments change as expected.

I have not saved any Parts.

When I leave the MIDI [SRC][STC] setup page open (so you can see the ch assugnments), whilst changing Banks, then the screen doesn’t update to show the MIDI ch. If I change to the other Bank, then select another track and finally return to the first track, the correct MIDI ch is displayed.

Saving the Project, switching off and on again, returns the correct MIDI channels.

Basically, everything works as you would hope, except sometimes the display does not update.

I could repeat the test for MIDI CCs, but tomorrow.

1 Like

thanks for your help:)

i tried saving all parts. it might have helped + placing a MIDI trig on the second pattern (D01).

EDIT; double-checked, no saving parts wasn’t the solution. it was the MIDI trig on the new pattern that did the job

2 Likes

thanks for your help. you helped me solve it. placing a MIDI trig on the second pattern (D01) means that it now behaves exactly as expected (phew!)

the goal is to have 4 channels of MIDI CC being converted into CV to sequence and modulate a small modular rack. I’ll feed the OT and some outboard synths (via the OT) into this modular rack.

thanks again:)

i was so close to having it behave as i expected!

1 Like

thanks for your help:)

it was all about MIDI CCs (not MIDI channels - I mentioned channels just to say that I hadn’t forgotten to set them to the same one, which is how i wanted them to be in this case). Basically pattern A01’s CC positions were overriding pattern D01’s, until I put a MIDI trig on D01.

I would consider it some kind of bug, as the OT isn’t actually transmitting the MIDI CC that it’s displaying - but there is an easy enough work around.

PS where is this ‘quote reply’ button? - ah, i worked it out… ok… apologies. next time i’ll use it properly

Its not a bug. Its normal behaviour. Eg, sending a CC until you tell it to send a different one, with a trig. Merely changing parts may not be enough to execute the change you want. (Depending on use case)

To quote replies, highlight text, hit the quote popup :slight_smile:

1 Like

ok, I have worked out quoting:)

but i was changing banks and patterns in this case. ok, i’ll accept that it’s not a bug and that the OT just behaves differently to how i would expect it to (not the first time and surely not the last!)