Octatrack footcontroller-pickup issues

Hello everybody,

I’m trying to use the octatrack as a looper. I created 4 tracks and programmed them as pickup machines as described in the manual.
But now I’m stuck here: I programmed all the settings to my footcontroller as explained in the manual but when I focus on the slave pickup machine and push the footcontroller for recording it jumps back to the master pickup machine and starts overdubbing on that one. What did I do wrong? Or is there something wrong with my machine? I have OS 1.25B. And I’m using a behringer FCB 1010.
Is this a known bug or is anybody having the same difficulties?

Haven’t gotten round to testing my yamaha footcontroller on pickup machines yet but i recall reading of a master/slave anomaly but i think that was to do with transport issues. I imagine all commands are on one channel, but if not check that (it’s multi chan on A4) and keep the midi rig simple to start ie just fcb>ot with one cable. It’s the setup they use on the official demo so it ought to be fine

Can’t seem to find a way to receive commands for the different tracks on different channels, I’ve just checked. You can only assign channels to trigs. But thanks for the suggestion nevertheless.

I’m using exactly the same setup as in the official demo. It works just fine. I can switch between the pickup machines by using the footcontroller as the describe. But when I swith to the second pickup (the slave) and start recording it automatically switches back to the first track (the master). If I do it manually it works just fine. So I’m think that there is or a setting that I don’t know of or a bug that I’m not aware of.


i’ll try later to confirm/otherwise your findings - see if it’s a midi settings related issue !

I’m using a Roland FC-300 as my foot controller. Never had any problem selecting a slave pickup machine track and looping on that one, other than the issues in the Octatrack itself, which have nothing to do with foot controllers (eg. “Dub Rec Aborted” and “Rec Mem Full” errors).

Not that I’ve experienced this one yet. But have you make sure that your “AUTO” midi channel is not overlapping with any of the TRACKS midi channels?

It’s as i thought and touched on, you need to use either the Auto Channel for all commands (although the pdf hints at only needing this for Track Select) or use dedicated record buttons for All pickup tracks (ie have multiple instances of Note 61,62 on different channels)

This has speed benefits because you can jump to recording another track without selecting it, it’s implicitly done in the Note definition midi channel

I could see your exact behaviour when I only used Midi Chanel 1 - that just happened to be the Master, it will jump repeatedly to a slave track if you start the master track on anything but 1

Simplest is to use the Auto channel on the FCB, most flexible is to set up dedicated switches :wink:

Thanks Avantronica, only got to it just now but it works just perfect! I send all my messages on the autochannel now. I was sending them only to channel 1 (and thus track 1) as you indeed suggested before.
Just got my octatrack a couple of days ago and it takes a lot of thinking sometimes how to set up things because the elektron universe is new to me but I’m amazed by what this thing can do.

yeah - it got me into trying it out properly - some thoughts here

a few other recent threads too - and [url=“http://www.elektronauts.com/t/pickup-machines-who-is-using-them/424/2083/page:1#2083”]here amongst others

i’m sold on it as a hassle free way to build layers with nice advantages but a few nuances - had a lot of creative fun with them