Octatrack not loading correct samples on track trigs when switching banks

Hello! Long time lurker but first time poster here. I’ve generally found most of my problems with OT have been answered in some way or form by searching the forums however I see to be unable to find a solution to this -

I mainly use the OT in arrange mode with my band and have set it up in such a way that each bank is a different song and have loaded different samples/patterns and loops in each bank. All tracks are disconnected and set to plays free; the issue is that whenever I switch to a different bank, the OT will play the previous sample loaded on the track on my initial press and will only play the ‘correct’ sample when I retrigger it. To make it clearer here’s an example:

Song 1 - Bank A - track 1 is a flex machine with a 1 bar drum loop.
Song 2 - Bank B - track 1 is a static machine with a long 1 shot sample.

When I switch to Song 2(Bank B) in the arranger after having played Song 1, the first time I trigger track 1, the drum loop(Bank A’s Sample) will play and I have to trigger track 1 again to get the long 1 shot sample to play (Bank B’s Sample).

I have ensured all the sample are occupying different slots in the audio pool and have tried fiddling with all the different settings in ‘pattern settings’ but to no avail. Is there anyway to program the OT to load and play the correct samples the moment the bank is switched?

Thank you!

You are in plays free mode. So the sequncer wont trigger a new sample until you do. You can place a trigger on the first step of the next pattern. This will trigger the new sample in the new part of your bank.

Thank you for the reply!

I have at least have a trig on the first step of each new pattern (often more trigs if they are flex machines) and the OT follows the trigs and plays everything correctly at the proper tempo set in each bank the second time I trigger it. However the issue is that the first time I trigger it after switching to a new bank and pattern, the OT will always plays the sample that was loaded in the previous bank and I will have to retrigger it again to get it to play the ‘correct’ sample.

I stop all tracks before I switch to a new bank so that nothing is playing in between the switching banks if this helps.

Man this stuff is so tricky to explain over the written word. If I was there in the room I could probably get a better clarity on your issue.

Be sure to understand the relationship between Banks, Parts, and patterns. Your answer lies there.

When you switch parts, you change all the settings associated for that part eg Sample. So you can link pattern 1 to part 1, pattern 2 to part 2 and so on. Save each part as you work.
Working this way means when you change from pattern 1 to pattern 2, the correct sample will play.

Did you try the “silence tracks” option (control/sequencer menu)?

Will this happen for each play free track separately or will it load all the samples for all tracks after the first “double trig” on the very first play free track?

Nevertheless a “dummy” helper trig may help. Add a trig with (for example) volume plocked to zero on the very first step. Then add your real trig on the second step and move it by microtiming all the way to the left so it is almost above the first step.

This way two trigs happen almost at the same time and it should work.

IMHO the silence tracks option only helps when the track is already playing when you switch …


I think that’s true, but one never knows… I have experienced the same behaviour recently (switching machines on the same track, using a different part for subsequent patterns, and the sample loaded in the previous part still in the play-buffer. I don’t remember what I did (I remember checking the AED and was able to observe the actual reload when restarting the sequence). It was not a crucial event at that particular moment so I didn’t pay that much attention but I noted the event on my WTF list. BTW, I was NOT in plays-free mode for that track.

Thank you everyone, I really appreciate all the help!

I did try the silence tracks option but the OT would still trigger the previous sample on the first press regardless of whether I stopped the sample before switching or switched with the sample still playing. It also happens to each plays free track separately, meaning I will have to double trig each individual track to get it to play the right sample in the bank we’re in.

The dummy trigger method suggested worked like a charm and the OT now plays the correct samples in the correct banks! Thank you so much!

1 Like

Strange, that you need double trigger…but If you don´t want to use microtiming you can use Arrangers mute commands.
Everytime you switch to a new bank, set up one row in the Arranger to mute all tracks in the first pattern and then let the Arranger trigger the pattern normally on the next row (use pattern length to shorten the pattern so it doesn´t have to play through it´s full length or manually select the next row).

Should work. :slight_smile:

Or just microtime all trigs on the first pattern on step 1, so it wouldn´t make a difference. That´s actually much easier lol

That’s a great suggestion as well! I have a couple of tracks with multiple triggers on them where placing a dummy would not be ideal so good to know there are other work arounds :slight_smile:

That’s cool but I still believe this shouldn’t happen…

1 Like

Yep, it´s quite strange. Also the behaviour appears to be quite consistent, which is odd.

Does this also happens when no sample plays on a track (loop=off, amp hold/release shorter than the track length) and you switch to a new bank?
Any difference between static machines and flex?

Nice to see a theoretical idea works in practise. That’s one of the things I like about the OT: even if it doesn’t work as you want you can find ways around …


I could try this call if you didn’t:

What would happen if you between songs manually changed Bank/Part and performed multiple [Stop] presses?


I was thinking of a short dummy pattern trigging the new part machines silently, without play free tracks. Is that what you mean?

Exactly. That‘s what I meant :slight_smile:
I didn’t think about that he uses plays free tracks, though.
But that‘s no problem, dummy patterns could be set to normal playback (plays free off) while all other have plays free activated, so after the dummy pattern the arranger changes to the next pattern and he can start tracks manually.

1 Like

This bug is Plays Free related. It doesn’t happen otherwise.

The arranger mutes thing is a good idea but, as arranger mutes differently, I suspect it wouldn’t trig samples and load machines.
Silent Plocked trigs, silent scenes eventually.
Edit : Empty pattern

For looped samples with 1 trig, it is possible to use trigs 9-16 to trigger the sample quantize or not (Track + Stop to stop, also Track + Play to play, quantize in Attributes).

For sequences, the dummy first trig seems a good workaround, but, using arranger anyway, I think I’d use a dummy pattern.

1 Like

I confirm with mutes in arranger it doesn’t trig part changes.

But playing a muted pattern made it work!
If you load an empty pattern of the same bank (and same part), the bug disappear, the first trig plays the right sample with Play Free.

Bank A Pattern 01 Plays Free > OK
Bank B Pattern 02 Plays Free > don’t work

Bank A Pattern 01 Plays Free > OK
Bank B Pattern 01 Empty Pattern
Bank B Pattern 02 Plays Free > OK

With such an empty pattern you should be able to keep previous pattern fx tails (no part change) so delay /reverbs can be used for transition.


I see. So this is a common bug?

Are bugs common you mean? :smile:

I didn’t know that one. Seems a bug.
Without Plays Free it works properly.

Btw writing this I had an idea and I think I just found a nicer workaround that seems to work:
SAMPLE LOCK the first trig! (Hold trig and turn Level knob to choose the right sample slot).

1 Like