OT and Launch Control XL issues

I’ve been using the Novation Launch Control XL with my OT in a live setup. I use Calc’s templates for the OT, mainly the master template as I need to control parameters on several tracks at once.

The main issue I have is that when I change to a pattern that uses a new part, the encoder and fader positions are in physically different places than on the OT. When I move the encoder, the parameter on the OT jumps to that value, creating unwanted sudden jumps.

Is there a way to make the knobs “catch” the value on the OT instead of jumping? Is there a setting on the OT for modes of midi pickup? Or can I change the knob behaviour with the LCXL editor?

For example, track 1 filter cutoff on is open at the end of a song, then I trigger a new part and pattern with the cutoff lower on the OT, even though the knob is “open”. When I move the knob, the filter jumps from closed to open to reflect the position of the knob on the controller. I want to turn the knob without changing the sound until reaching the value on the OT.

Any help is much appreciated.

Hey Negmo,

Great to hear you’re using the LCXL with OT… It really opens up the OT’s engine a treat!

Genuinely brilliant to hear that the work opening up the LCXL to host to MIDI converters is being used out there too… it makes me feel warm inside :joy:

You should also check out Neil Baldwin’s LCXL/OT template, I actually think it’s a more useful layout than mine. Although I still need the bottom set of buttons as MIDI track mutes but that’s easy enough to configure.

With regard to your question about “MIDI pick-up” behaviour, Unfortunately I don’t think this is possible. At least I can’t find anywhere on my OT that lets me set-up that type of behaviour.

I would love to be proved wrong though… so if anybody else has a suggestion please chime in.


1 Like

There are no ‘knob mode’ settings in the OT.
One thing you could try (if you have a free button to assign) is sending a parameter request cc to the octatrack. I can’t remember offhand what the cc# is but it’s in the manual.
This would obviously require you to send the parameter request after switching.

1 Like

sorry, but where can I find Baldwin’s tamplate? Could you help please?

Hello !

Here comes a new user of Octatrack !

It happens that i have a Novation Launch control XL around

But i cant find Calc or Neil Baldwin templates on the site … am i just too limited for using an OT ^^ ? can someone help me ?

Edit 1 :
Just found Calc template on Novation site :

Thank you for this Calc

1 Like

Hey No Problem Amniil… glad to have been of service!

Took a little while but I eventually found Neil Baldwin’s Template.


As I’ve said before I think this is a great layout and maybe more usable to some folks than the one I did.

Hope it helps



Thank you Calc for the answer and the link !

I am going to try both templates as soon as i receive my Usb host converter

(then probably modify one of them to have 8 knobs assigned to Cue levels !).

Has anyone used the Launch Control with Mode Machines Cerebel Usb midi converter?

I bought the Cerebel a while back with the intention of using with the OT and Launch Control, but only just got the LCXL this week.

Installed Calc templates but am having issues with picking up midi which comes through intermittently and lagging. Values on the OT are skipping through steps abruptly and won’t travel through all values despite the rotary encoders on the being turned fully left or right.

Faders aren’t working either, they go up and down but not smoothly and will jump back to initial settings.

The firmware on the LXCL is up to date.

Midi set to channel 11 auto and both midi and note set to in and int_ext

Any ideas where i might be going wrong.?

its the controller…not the host…had the same problem…now using akai midimix

Hey horizon eyes,
got the same problem, as well with the cerebel. Could you figure out sth?
The values to which it jumps are not the initial values from the OT, so it comes from the outside. But how can it be the controller, because some guys got it to run. Maybe the new firmware update 1.2 got some bugs? Would try the old inofficial firmware, but I cant find it any more.
Does anyone got some hints?:slight_smile:
Thank you!

Hey Guys,

fnnkrz asked this on my YT channel too and this is what I’ve responded with:

Hey fnkrz fnkrz - Sorry to hear about the issue! I also read that about the Mode machine’s Cerebral but I’m not quite sure where the problem will be.
I do know that the LCXL works perfectly well with the Kenton host to MIDI, Bomebox, Iconnect MIDI4+ and the Sevilla soft UHM so my feeling is that the problem could potentially be somewhere with the Cerebral. Sorry I don’t have access to one to test for you.
I can most likely get hold of the older Firmware for you from work but I’m not convinced that will help.
It’s all down to the way that MIDI data transfer is set, the older firmware was set to Interrupt data transfer request. Interrupt is faster and more streamlined but not technically true class compliant, the newer firmware went back to the bulk transfer request standard which is actual true class compliant. In the real world, it still works exactly the same but means that LCXL will now work with USB hosts.
LCXL was obviously developed originally as a USB computer controller and the computer’s OS and USB controller managed the original interrupt request transfer treating it as a class compliant device. So now with the 1.2 firmware the LCXL is definitely class compliant in the true sense. I believe Interrupt was decided on as a way to make the Launchpad S a faster grid controller than the original.
To the best of my knowledge all the Host to MIDI converters need true class compliance (i.e. bulk transfer request) although I know that John from Kenton was looking at changing his box to also accept interrupt request based devices too.
As for the older firmware I can get hold of it if you want but unless the Cerebral is set to also work with interrupt request devices (which I assume it isn’t as it’s technically not class compliant)… I can’t see that actually helping you… sorry about that. If you do want to contact me direct drop me a PM on Soundcloud.com/calcutt (or get in touch here too!) and we can pick it up there.
You could also try the Novation support team, you can get hold of them from the website… they’re a good bunch :o)

I’ve also contacted our Novation support team about it and I know that Inspektor Gadget (I think that’s spelt right) is sometimes on the forum too… hopefully between us we can see if we can sort out this issue.

I did notice that the Cerebral page on the Mode Machines site is saying that the Launchpad S is tested and working with the Cerebral… this is strange as if I remember correctly the LPS is still on an interrupt request standard. so that makes me think that perhaps the older firmware could potentially help??? Hmmm!

Also did any of you adjust the templates I made for the LCXL or keep them as the download? it would be good to know.

Anyway I can definitely vouch for the Kenton, Bomebox, IconnectMIDI4+ and Sevillesoft UHM, as host to MIDI converters they all work a treat and (in my humble opinion) the LCXL is a perfect controller for the OT when it’s connected!

I know this is not a solution but I’m hopeful there is something we can do to get this working.



1 Like

same problem here with Cerebel USB + LCXL with latest firmware installed,
the “funny” thing is that if I connect the MIDI out of the Cerebel to the MIDI In of an Audio interface it works, but when connected to the MIDI in of the OT everything is a mess :frowning:
Did you guys figure it out in some ways?

I am sure you are correct and I am missing something, but I cannot get it to work with the Bome Box. I have saved the OT templates to the editor just fine. I have made all the correct routing adjustments for the Bome. I have sent the 1.1b3.syx file to the XL (have no idea if it worked or not as there was no led indication that anything was happening).
When the XL is connected as you would for editing and .syx dump, it seems to be correct, yet when it is connected to the Bome host, it dies (as in…bottom 2 rows are chasing red leds followed by a short led flash of all encoders. It will not respond to any input at all. I have no idea how to get this thing up and running.
Any suggestions would be appreciated.


It does sound like it’s the 1.1b3 that’s causing your problems.

Try version 1.2 on the official downloads page.


Hey PS,
Yes it is running 59 I believe. I have flushed out everything over and over and started again using both C6 and the Sysex Librarian and it all seems to come down to the LCXL not recieving that 1.1b3 file.
It really has me stumped. You can clearly see that the XL has been populated with the 8 templates, but as soon as I swap out the usb to the Bome Box, I get nothing. If it means anything, I am running OSX 10.10.5

Oh and as bonus info, I loaded and sent that master track sysex file directly to the XL and it seemed to take it. Pretty LED show and all that, so it is my belief that the 1.1b3 file is not working for me.

sorry that was meant to be a reply.

points up

Hi Steve,

I actually got my Bomebox out yesterday and tested it, and after a firmware upgrade on the Bomebox everything is working perfectly. Initially I did have a few issues with connecting to the Bomebox network but after a chat with the genius that is Florian Bomers! it was soon sorted.

I’ve checked out my LCXL through Bomebox too and it’s working perfectly and sending MIDI out to my MIDI monitor as expected.

When I spoke with Florian yesterday he did say that the only issue he’s had with Bomebox is power supplies not being strong enough. If your LCXL is not responsive through Bomebox this sounds likely to me too. infact this is what Florian actually said… (I’m sure he won’t mind me quoting him :o)

“Regarding issues with LCXL: it’s most likely a power problem. Otherwise said, the only issues we’ve had so far with production BomeBoxes is issues with USB power supplies. Some power supplies just don’t have enough headroom so when there is more current needed, voltage goes down temporarily. In particular when using a passive hub, such a voltage drop can be problematic for powering USB-MIDI devices. The best answer to that is to either not use a passive hub, or to use a powered hub. You can use one of the hub’s ports to power the BomeBox, too. The other option is to use a (cheap) PoE injector for powering the BomeBox using the PoE In Ethernet port. It provides 48V power, which is converted to rock stable 5V inside the BomeBox :)”

I’m using an Apple phone charger to power mine and it seems pretty solid.

I hope that helps you at little. If you are still struggling I’d recommend contacting Bomes directly and seeing if they are able to help.

All the best and good luck


Thanks for the reply. I must say this whole setup is really confusing me now and frustrating the hell out of me. I am now powering the Box from the wall and the only difference that has made is a different light show. Still totally unresponsive. What is the difference between the 1.1b3 file from the Beta site and the XL Updater 1.2 on the official site?
When I first set the XL up I downloaded that updater and it updated the unit to version 59. I then tried to send the 1.1b3 fiIe.(probably unsuccessfully). Then opened the editor and loaded all your templates. Indications from the XL were as expected. Good so far. Then I plug the usb into the bome box and get no response.
May I also ask, Do you know what the 4 types of ins/outs on the LCXL? When setting up the routes in the bome, there are 4 XL in/out types LC 1, LC 2, USB LC 1, USB LC 2, What does that mean?
To summarise, I still believe that the issue lies with either the 1.1b3 file and/or the 1.2 updater. The only difference a different power source has made is with the LED display. It still does not respond.

Sorry to be a pain.

1 Like

I have just gone into the Bome Midi Route page again and the LCXL inputs are showing as pending?