OT randomly issue « file not found » when changing sample with Fn+Left/right arrow

Im working my live set with the sample swap technique FN+ left or right arrow.
But totally randomly sometimes when I swap sample during playing with this technique I have a message « file not found » :cold_sweat:

The bug happen with sample loops from internet from different packs and with loops that I record with the OT with ABCD :worried:

So I tried all of this process but the bug is always here:
-Factory reset the OT
-Update OT the the latest firmware
-Format my CF card
-Tried 2 another CF cards
-Erase all the .OT files from my set
-placing all my sample into 8 folders like (T1 = all he sample I’ll play only on T1 and so for all the 8 track) I recommand this method better organisation and when my bug happen it’s more easy and faster to find the missing sample.
-making a new set / project with my sample sorted like I said up :point_up_2:without .OT files.

Guys il totally disappointed :disappointed:
I followed advices and help from @Rusty and @sezare56 big thanks for your time.
I send a ticket to elektron, no news

If someone has the same bug please tell me and explain me how to fix it :pray:

1 Like

Salut. Would you post here some buggy files, so that we can test them?

Salut :wave:
Yes i will upload my set to mega.co and post the link here.

Here you can download my buggy set.
The bug randomly coming when i change sample with Fn+ left or right arrow.

Test it with multiple swap sample with T2, T3, T4, T7 and T8 and tell me if you have the same bug.


Done. 371 MB. Many files! T1 / T5 / T7 were empty.
I tested most of them with FLEX and STATIC. No errors. :sketchy:

Maybe you can make a smaller test folder with less files, if someone else want to try.

MKI? OS 1.30C?
I’m on MKI 1.30B.

1 Like

Its normal
T1 =inA
T5= inB and
T6 =inC
I use this tracks for live recording my inputs.

Try to swap samples with Fn + left / right arrow many times with T2 T3 T4 T7 & T8 during playing and tell me if you have the « file not found » error message.

I have the MK1 and latest firmware. I have the bug with 1.30D too.

That’s what I did. I didn’t have that message.


Thanks for the test @sezare56
I will try with a friend on his OT when he will be avaible.
It’s a F###ing mystery bug and it’s really unpleasant :worried::exploding_head:

Os 1.31?

1.30C you mean? 1.30D was delivered with new MKIIs.

I’d would be interesting that MKI users with the OS you have / had test it too.

Ps : You told me in private you tested with other CF cards, not sure you precised it here.

Since I have my OT I have always update the firmware.
I don’t remember which version it was before I update to 1.31.
But I think it doesn’t matter because the bug « file not found » was present before I upgrade to 1.31.
And bug is present in 1.31 too.

Yes i tried with 2 another CF, it’s mentioned in my first post.

1 Like

Hi @Gat.
I downloaded your Techno Set and reproduced the issue twice (got only 15mins free tonight) for T4 files.

Just swapping samples with arrows on one of these track did not show any error but swapping samples on several tracks very fast, one by one, almost simultaneously did show.
I’m not sure if it is issue for the given Set or just behaviour for Card>RAM loading
(requires tests on another set).

After every sample swap there is the ‘Loading’ message shown on the slot row for a short time (depends on file size). For T8 there are bigger files / longer loops prepared to swap and load. When I was switching samples on T8 and jumped (very fast!) to the T4 to do the same (probably during still loading T8 file) the ‘Error: File not found’ appeared.
Maybe it is impossible to load two files at the same time?
More tests could reveal more details but this is not my workflow and will probably never meet the issue again.

PS: I’m not techno guy at all but these loops and sounds in the project are really cool.:cheeky:


I wouldn’t call this a bug per se, because this kind of sample switching is more a hack than an intended use case.

When the file system on the CF card gets under stress it simply doesn’t respond fast enough and the OT interprets this as “file not found”.

I don’t think you can do much about it other then not scheduling another switch while there is still one ongoing and - maybe - use shorter files. A faster card may also help a little bit, but in general the same rules apply as with static machines: streaming is fine, everything else may work, but isn’t guaranteed.

1 Like

Wirh 1.30B it worked perfectly for me, with Flex and Static.
I think there is a new bug possibility.
It would be interesting if some nauts with versions before 1.30C would try too.

Big up man :sunglasses::metal:
You find it, im not only.
Yes in live situation i fast switch sample because some sample dont feat well with another Sample on other track so i instantly swap some samples like a Ninja lool.
I use a CF transcend UDMA7 64gb 400x speed.

I tested my set on the 2 other CF card same issue.
So it’s not due to the CF himself I think.
So I find my worflow with this setup by swaping sample « a la volée » and I love it.
Maybe elektron can say or make something about this bug.
I create a ticket but no reponse from them :face_with_symbols_over_mouth:

Could you please test to reproduce the bug but with your samples, not with my set.
And tell me if the bug appear to.
Thanks you

Been discussing this on FB with @Gat; think might be a speed issue [ i.e. buffer | file i/o ]

So suggested to try doing it slowly and see if can be replicated.

And maybe best to use Sample Chains et al instead…


I deliberately did not use the word ‘bug’ because like guys above I think this is speed issue. It could be better to reorganize your workflow than forcing Elektron to correct this.
Making sample chains or maybe placing all samples you swap in 1 directory on the card instead of 8 folders? I don’t know.
(MK2, 1.31).


Technically spoken it’s not about speed, but latency. Behind the curtain the OT requests a directory listing (to analyse what file is the next/previous one) and - sometimes - it doesn’t get the answer in time to fulfill your request. So what should it do? Try again later out of sync with your request? The only reasonable solution is to notify you about the situation.

“file not found” may not be the correct wording for the problem beneath, but even if it writes out more correctly “file not found in time” this will not change anything.

The only thing Elektron could do is cache directory listings in RAM so it doesn’t need to query it just in time, but that would require a not negligible additional amount of memory and needs to be incorporated into all functions which accesses the CF card.

From a realistic point of view such a change will not happen that late in the lifetime of a product.

The only solution to this is to modify your workflow. When you want to reliable switch fast between samples, the samples needs to be at least in one of the slot lists, so the OT knows upfront of it’s filename and doesn’t need to query the file system. Or even better (as already suggested): use sample chains.