OTC V1.0 Octatrack Randomizer

Hi everyone

OTC V1 [Reaktor ensemble] is finally in the files section!

New features:

-Min and Max values for each parameter for better control of the randomization
-Value display
-Randomize per Track
-SCENE WRITE

Some improvements, still a few bugs to be fixed

Enjoy

L~N

Awesome!

Cheers mate!

hi, been trying this today and everything seems to be working for me but the scene write… could you elaborate a bit more on the scene write section? i tried but is not working, tracks light don’t seem to go from 1 to 8 as i click the “write” button, it stays on T1 and randomises more the OT (?)then have to reload the part to get whatever i was doing back…… thanks in advance

Hi
First thing you can check is the Auto Channel instrument in the Reaktor ensemble. If you scroll down you should see it. The instrument only have 1 button called “track down”
Now make sure this instrument is connect to your midi output and on channel 11[ in the Instrument properties ]
Then select a scene you want to write on the Octatrack
Press T1 [track 1] on the OT
Hold down “scene A” on the OT and press the “write button”
you should see the red LED move down to track 2 etc
Once it is on track 8 all the parameters affected by randomization should be written to the scene
[Note that only parameters selected for randomization will be written. If you don’t want to write some of them just uncheck the red buttons next to the cells]
I hope it helps and that you can get it working
Most likely the problem comes from the “Auto Channel” instrument, just make sure it is connected to your midi device

there is 2 major bugs I am fixing at the moment

  • When you save a snapshot sometimes the “randomize” buttons of track 1 and 2 don’t recall properly [already fixed]

  • When “quantize” is on for LFO speed for example, the “min” and “max” values are not working properly, I figured where the problem is so I will fix that and post a fixed version in the next couple days, it takes time

Let me know if you encounter other problems

I hope the scene writing works properly, feedback is welcome :slight_smile:

Hi, the auto channel thing worked, the OT has to be in the same one for the tracks to go down. Now, when i click the write button there seems to be more randomisation going on, making the one you want to write slightly different. Then, the master reset doesn’t seem to be working, it randomises a bit more then the sound cuts out, the only way to get it back is to reload the part, loosing the recorded scene. I’ve been copying the scene to other pattern with a different part, then reloading the part in the original pattern, and copying the scene back into it, then save the part and begin over again. I don’t know if Im doing things right by the way, but the reset master is not working for me, but it was working on the first demo you posted.
will let you know if i find more problems
Best

When you press “reset all” are the settings going back to default on the reaktor ensemble? [pitch=0, Rate=+64 etc]

There shouldn’t be more randomisation when you press “write”…

Some ideas:

Try to set the OT auto channel to 11

And only connect reaktor out to OT in

Also try an empty project with no neighbour tracks and default filter and delay effects for each to see if it works properly

Try this and let me know

Hope this works

Anybody else experiencing problems like this?

Hi, when i click reset master, all values on the reaktor ensemble are reseted, but the octatrack doesn’t go back to its original settings (your previous demo did this), it stays with the previous randomized values. When i click write some more little randomization goes on. The auto channel in OT is on 11 and only out from reaktor is to the OT. no neighbour machines are used. Will try the scenario you suggest and let you know.

Just to be clear, this is the way i think it works. You randomize the ot, when you have a setting you like, you can write it in the scene you want with the write button (click it 8 times and the tracks go down, all good). When you have the scene written onto the octatrack, click master reset to get your original sounding pattern. But master reset is not doing it, i cant. Can make a video to show you whats going on.

Yes what you are doing it right
Something is wrong for you but I can’t figure out what it is…
“write” should not send new values, but trigger the existing ones and moves to the next track
If you can do a video this could help me understand

Hi, here is a vid i made

When i hit the write button no randomization is on, but the effect is the same, at the first click it randomizes a bit more.
Im using reaktor on osx 10.7.5
Hope it helps

So is this normal?.. Anyone experiencing these issues

I got a B I G request for you :stuck_out_tongue_winking_eye:

I use snow leopard in my studio, OS no longer supported by NI and ensembles built in reaktor 5.9 or above simply won’t open.

Sooo the req is:
is a real pain in the arse to make a reaktor-5.8-compliant version of this awesome ensemble?
I really think that should make a lot of users very happy

let me know and thanx in advance

Dear alex3368,
i don’t know exactly your Problem but i have the Problem to install Komplete 7 on Yosemite and the solution i found here:
http://www.native-instruments.com/forum/threads/yosemite.228464/page-2

Here the important text:
Fortunately you can fix it:

  • Copy the Kore 2 Installer Mac.mpkg from the ISO to any directory on your mac, so that you can modify it.
  • On the mpkg right click > Show package content
  • Edit the Contents/distribution.dist file with any text editor and remove the lines 8 to 11 in the pm_install_check() function (this is where the version is checked as the name says)
    You should have something like this
    function pm_install_check() {
    return true;
    }

If you don’t feel like editing the file, here is the modified file (attached), simply replace the one in the mpkg by this one.

Then double-click the fixed mpkg and the installer should run fine.

You can then run the 2.1.4 update which won’t require any kind of fix.

Here on a fresh Yosemite install on my 2013 iMac, Kore 2.1.4 + Kore 2 controller work as expected.

Hope it helps,

Laurent

All the best,

waldemaR

Bassline: I am currently working on fixing the last bugs before uploading a new version, let’s see if you will still have those problems with that one
I will also try to make time to do a tutorial video and a manual, it will probably help
Hopefully it works fine with other users but you are the only one so far to give feedback on this version…

alex3368: I am looking for a way to save for older versions but not sure it’s possible

waldemaR: cheers for the help, hope this works for Alex!

Thank you so much mate, I’m crossing my fingers…
Damn, this ens is a must have

I’m intrested in this thing, but to new to OT.
In Future will be a Video to explain?

Thank you.

All the best,

waldemaR

Thanks L~N, hopefully someone else will comment on it. Will wait for the next version. Great work!