Passing incoming midi notes to midi OUT rather than THRU?

been trying to connect midi keyboard to ot to play synth further in chain, but didn’t find a way. it works only with midi thru, but ot also sends clock and everything, so i need it in midi out. is it possible?


In MIDI mode, notes received on the auto channel or the MIDI channel of the active track are mixed with the MIDI data sent by the track. Incoming notes will also be arpeggiated according to any arpeggiator settings made to the MIDI track. Depending on the CC DIRECT CONNECT setting, incoming MIDI messages will be handled differently. If the setting is activated, MIDI CC messages sent to the auto channel or the MIDI channel of the active MIDI track will be sent straight to the MIDI output port. When in LIVE RECORDING mode, specified CCs in the CTRL 1 and CTRL 2 SETUP pages can be recorded by the sequencer. If the setting is deactivated, the MIDI tracks listen to MIDI CC messages according to the MIDI MODE MAPPINGS table found in “Appendix C: MIDI CONTROL REFERENCE“. Note that MIDI CCs 36-45 sent on the auto channel will be remapped according to the CC messages specified in the CTRL 1 and CTRL 2 SETUP pages. The only exception to this is if MIDI CC messages are sent to the MIDI channel of the active track. In that case, the Octatrack will behave as if CC DIRECT CONNECT was activated.


appreciate your thoughtful response!

so when i turn midi mode, select track 1, set ch.1, is OT supposed to pass midi notes from keyboard (talks ch.1 as well) to my DN, which listens to ch.1 on track 1? tried this, didn’t work. i’m not interested in passing CC messages (so far), i want just midi notes get through OT via midi out to DN :slight_smile:

EDIT: i got it. i need to use OT’s auto channel and then ‘reroute’ channel from OT further in chain.
thanks for your help!


having a similar problem

using a Novation Impulse 49 midi controller, into the OT’s MIDI IN
then OT’s MIDI OUT goes to a Volca Keys

I want to send clock from the OT to the Volca, but MIDI NOTE data from the Novation through the OT without the OT taking any itself

Novation on MIDI CH9, OT MIDI AUTO on CH9, Volca set to CH9
Track 4+6 are pickup machines for looping Inputs C+D aka Volca Keys
OT MIDI menu, double click SRC and set CHAN to MIDI CH9

I can now get the MIDI NOTE data from Novation passing through to the Volca, but only when I’m in the MIDI tab itself which is frustrating

Any ideas?

Don’t use the auto channel. IIRC: set impulse to channel 10, for example. Make a MIDI track on Octatrack also set to channel 10. Set volca to channel 10. Might be missing a step :slight_smile:

1 Like

Urgh worked instantly thank you so much

Digging this old thread up again.

I have a very similar problem. Only that I would like to have the OT forward all channels’ MIDI messages from it’s IN to it’s OUT. It works with the described method above on the AUTO channel and the active MIDI channel. That doesn’t help my use case though:

I want the OT as the clock and have a Firefox control a Syntakt, which is slave to the OT, so I need to merge the OT’s and the Faderfox’s MIDI data.

I can achieve it somewhat via MIDI through if I have the OT as a slave to other devices, but I’d prefer it to be the main for best accuracy.

:thinking: But the right method is to set midi tracks with the channels you want to pass thru midi OUT…8 channels max.

So this is, in fact, supposed to work? I’ve skimmed through the manual, and the only section I could find - to me - reads like this use case is not supported. That’s the section also referenced by @Schnork.

To try it out regardless, I went to MIDI mode and assigned 2 tracks to different channels (1 & 8 in this example). Neither in MIDI mode nor outside of MIDI mode do my Syntakt tracks 1 & 8 react to any incoming signals.

Only when I change the OT’s outgoing cabling from the MIDI OUT port to it’s THRU port, does it start to work (without any other re-configuration of any cabling or machine). But then I can’t have the OT be my main clock anymore again.

I must be missing some setting then?

It is because your audio channels are set to 1-8. You can use channels 9-16 or :
In MIDI > CHANNELS set them to different channels or OFF. These channels are audio track channels.

Why ?

HOW MIDI IS ROUTED If an audio track and a MIDI track share the same MIDI channel, the MIDI track will block the audio track from sending out data while the audio track will block the MIDI track from receiving data. In the PROJECT menu you can see which MIDI channels are assigned to which audio tracks.


:heart_eyes: OMG thank you so much! That was it! I had even read that part. But I guess I was too stupid to understand what this really means :see_no_evil:

Really appreciate your help and patience :pray:

1 Like

Not obvious ! :content:

1 Like