Pattern Switching

I realise this is a super basic question but its got me baffled, Ive been using the OT at a very basic level, just creating a single pattern for each project, having a jam and moving on. Now Id like to be able to switch between patterns in a project.
I have read the manual and they make it sound very simple, hold down the pattern key and press the trig key to move to the next pattern, or to chain them hold down the pattern key and press and hold the trig keys in the order you want them to chain, a single arrow or a double arrow will appear respectively.
I follow these instructions to the letter, I see the single arrow or the double arrow, but the OT just keeps playing the pattern Im on, no switching takes place. I stop the playback, and it switches to the next pattern, then I press play, the next pattern plays (A3), I hold down pattern and press (A1) and it switches to A1, then I try to go back to A3 by holding down pattern and pressing A3, but nothing, it just carries on playing A1.
Sorry to ask but its got me proper confused
Thanks for your help

Ok, perhaps I asked to early, quite typical of me, Ive worked out that it wasnt switching because I had the master scale length set to INF, It was set to inf because Ive got some pretty complex polyrhythms going on and I wanted them to continue without restarting.
ive now set it to 64 and the pattern switches at the end of 4 bars,
So as an update to my original Q, is there any way I can have it set to INF and still have it switch after the 4 bars?

Yeah there is, I’m not next to mine at the moment but there’s a change length possibly accessed by Function + Bank, although it may be you have to be either in or out of grid record to reach the right page. A lot of those button combinations are a bit trial and error for me.
The INF thing is a bit of a bodge really, IMHO. Much prefer the Sequentix way that involves a “global bar” to which patterns can sync or not.

yup… func+bank when not in grid record. chain behavior–>use pattern setting. same place you set the scale mode to be per track. you can also set it for the whole project in the control menu.

Thanks very mic gents, appreciate it