Recording Latency in Octatrack - Bug?

Continuing the below thread from Elektron-Users, where other users have also noticed recording latency in Octatrack. I have run into an issue where it seems like the Octatrack is adding latency to my recordings and also the audio being monitored through the Thru Machines.

I will try to be as concise as possible.

Consider my setup: OT and RYTM are synced via Expert Sleepers ESX-8MD. No jitters here. Ableton is the master.

Consider the following test I did:

  1. Record the RYTM’s metronome directly to Ableton. Audio is on-grid.
  2. Record OT’s metronome directly into Ableton. Audio is on grid.
  3. Feed RYTM directly into OT via RME TotalMix.
  4. Record RYTM’s metronome into Ableton from OTs output. Audio is LATE.
  5. Record RYTM’s metronome into OT recording buffer #1.
  6. Record OT’s buffer #1 into Ableton. Audio is LATE.

It seems clear to me that OT is adding latency to its audio. Again, OT’s metronome records just fine into Ableton. Given that RYTM was routed directly into OT, it seems unlikely there is additional latency happening there.

I have tried checking the latency compensation option in OT, but that did not do anything. The fact that there is such a thing in OT makes me very suspicious that OT is actually adding latency or has to add some latency by design. I wonder if it is due to the delay FX I have on my OT tracks?

Anyone have any thoughts about this?

Really appreciate it.

Did you try to route Rhytm straight into OT, without RME TM in between? AFAIK RME introduces very subtle latency, practically non-detectable but I can imagine that on sample level you can see it. How late is your recording in terms of ms or samples?

1 Like

Thanks for the reply. The latency is in the hundredths of seconds. I definitely “feel” it when syncing Ableton beats to RYTM’s beats going through OT.

Last night, I did four tests:

  1. RYTM->RME->Abes->RME->OT->RME->Abes
  2. RYTM->OT->RME->Abes (RYTM plugged straight into OT)
  3. RYTM->RME->Abes
  4. RYTM->RME->OT->RME->Abes (RYTM routed through RME using direct monitoring)


  • 3 was lowest latency.
  • 4 AND 2 were higher latency, but about equal to each other.
  • 1 was highest latency.

Shake-y conclusions:

  1. OT is indeed adding latency.
  2. RME is not really adding latency in its internal processing.

Possible workaround: Monitor everybody through OT - including Abes. I have not thought through all the downsides to this one, but one obvious one is any VST synths monitored through Abes will incur the additional latency introducted by OT.

I tried to be as objective as possible, but it is of course still possible I made an error.

Hello everybody,

is there now a workaraoud for the latency problem? I’m doing live recordings with OT, i.e. I sample percussion elements (shaker, cabasa, clave, snare etc.) in a live-techno setting. A MPC sends clock data. Every machine is sync, of course, including OT. But when I sample/record and replay the recordings, OT adds latency to the replayed recordings. This is non-excusable in our setting. (By the way, I use OS 1.25H)

I could use the micro-timing, but I am not sure, whether the latency added is always the same, and there is also a consistency problem.

So the fundamental question is: Is this really a bug? and if yes, is there any convenient workaround? And has Elektron stated something in direction of fixing the bug?

Thank you for answering!

I use OT as master for recording because midi clock tempo can fluctuate. I disable Timestretch (Playback Setup TSTR = off)
I realtime play my guitar recordings with effects, with a very little latency (1.5 - 3ms?), which is normal.
I can turn off direct sound so it is not annoying.

What’s your latency ?
You can resample and make a selection to check the latency.
Once I recorded a sample from Ot, cued and recorded with input AB. 3ms latency with DA/AD.

1 Like

I recently repurchased an OT, so this issue has surfaced again.

How do y’all handle this case?

When triggering my iPad from the OT’s MIDI sequencer and monitoring through OT, the latency is not too bad.

I then sample the same sequence using a one-shot record trig (as I normally do to get perfectly cut samples).

When I assign that sample to a static machine and play it back, it is late and off time.

If I play it at the same time as the MIDI sequence, the sample is late, but the MIDI sequence is on time.

I am NOT syncing; I am simply sending MIDI from OT’s MIDI sequencer to iSEM in the iPad.

Is the OT adding latency in the recording as discussed here?

What I do to handle this is simply slice my recording by transients, 2 slices, and then just trig the sample that way. It is lined up correctly thereafter.

Basically, why does OT not record exactly what is heard in the monitoring?

Either Thru machine or direct.

Any ideas? Is there a better way?

Many thanks!

In this recent case, I had accidentally set my record length to 63 steps, not 64. That explains that. Leaving this up for any other poor bastards that happen to run into this.


Another occasion to ask :
Why 64 steps max ? Quantize Rec is 256 max,
A pattern can be 1024 steps long. :thinking:

@Open_Mike, did you change your mind about that ? :wink:

64 steps so that my loop is perfectly cut for 64 steps.

Sorry, I was asking to @Elektron, that is just another highly important feature request for musicians recording longer than 4 bars…
1024 steps max would be :heavy_heart_exclamation:

Unfortunately you can’t set longer recordings than 64 steps, even if you use a different scale like 1/8, because recorders don’t care about track scale. Manual rec stop or midi messages are the only workarounds.

1 Like

I miss my Octatrack still napping in storage, must get back to it soon… :open_mouth:
I’m with ya though, +1 for high rlen values all the way…

1 Like

Hey @sezare56 - maybe you would know the answer to this.

So, my issue was actually not my RLEN. I know that because I reproduced it with RLEN = 64. There was something wonky in the static machine. I switched to flex and back to static again, and then the problem went away. It was like the playback position was off in the static machine, but I could have sworn I cleared the SRC settings before I tried the aforementioned switch.

Any ideas about why that happened?

It seemed to happen intermittently a couple other times too on a different track.

Thanks man!

Did you use slices / start points ?
So your latency problem is when you play the recording ?
Try to disable timestrech.

Flattering but I have to say anybody knowing can answer. Nobody knows EVERYTHING about OT. Especially with new bugs eventually ! :smile:
I didn’t read about any specific differences bugs concerning MKI vs MKII ?

I’m guessing that in the second, later problem I had in this thread, I might have accidentally had a slice or start point changed.

However, before I did the machine switch, I cleared all the parameter pages.

I’m going to keep an eye on that one.

For the first original problem in my OP, I still don’t know what happened there. I have not tested that since I got my new OT.


Hey all, has anybody resolved this issue ?

I’m on Windows running Live 11, Babyface is receiving audio from OT while my DT and DN are ran through OB.

DN is syncd to Live 11 clock and it is sending my OT and DN the Midi clock, all seems fine until OT comes in, it’s always off time ! Sometimes it’s too early or late depending on what my settings are in ableton . I’ve tried In vs Auto and also tried turning on/off the ‘reduced latency when monitoring’

Pretty sure it’s the OT causing the latency but can’t find any way around it permanently

It is not, it is ableton, google ableton live midi clock problems.

1 Like

When send midi clock and a monitor a machine back through the OT, I get latency.

If I don’t run the machine through the OT, everything dead on.

To fair, this situation under that scenario happens with all my boxes - MPC, Circuits, Digitakt.

Just a reality for me

MPC (new ones) and DAW have terrible midi clock jitter, to the point of being unusable for me, over 2ms jitter.

Elektron gear has good midi clock, >0.3ms jitter.


~12 years ago, my band tried running two Ableton’s sync’d. Our experiment didn’t last long. We ended up just using it to play synths or trigger samples, with no sync and no sequences. I’m surprised it’s not improved in that time.