Waves not showing in Editor

I’m having trouble wrapping my head round this. Sometimes when I load a sample in a flex machine, then go into the editor, the wave does not display or preview. Yet it plays fine when I add a trig? Anybody know whats going on here?


Have had that as well, but I don´t remember what the issue was. Perhaps an recorder trig being active somewhere?

Using a Flex Machine, samples waveforms aren’t displaying in the Editor. I can hear & edit it fine, but zooming in and moving around on does nothing.

This question was raised awhile back https://www.elektronauts.com/t/waves-not-showing-in-editor/11695 but it wasn’t resolved.

Any ideas?


You could be viewing the rec buffer rather than the assigned slot?

Edit: oh so you can (for example) change the start point in the editor and you hear the change? Strange. When you say zoom you include vertical zoom yeah? Otherwise was going to suggest select all and normalise…

Yes, I can change start points, normalize, etc and hear it change. But even when I zoom vertically or name the sample and assing to a different track it results in the same – just a block with no waveform.

I’ve opened a support ticket with Elektron and will post any info here. It’s mysterious!

Weird, what OS are you on?


SOLVED! the audio was only in one channel and the Editor view was only showing the empty chanel. You can change the view of the Editor by pressing [FUNC] + [BANK] and choose Change View and then either Show Stereo view or CH R.


The famous ghost of the left channel ! :ghost:

1 Like

I love it when the OT makes you think it’s broken and then you find there’s a perfect reasonable explanation.
(I think the general trend would be to not like this one bit but for me it’s part of the adventure :joy:)

Just last night I recorded a Rytm loop and was met by a very high pitch whine on a warped up flex track playing the buffer. I’d done this on the same pattern hundreds of times. Started checking things, reloading part, re-recording, still there. :thinking:

Turns out I had raised the resonance on the high hats so high the rytm was playing an inaudible frequency. The flex track had rate at 32 which brought this frequency into the audio range but was still super high pitched, perfectly reasonable. Cool part was I then got to play with this ghost pitch using the rate knob. :slight_smile:


Literally just unboxed my new Octatrack mk2. Totally new to Octatrack and going through a step by step tutorial to sample for the first time. I too am not seeing my waveform. I saw a previous comment stated that it can’t be seen in a flex track?

In the tutorial it’s setting the tracks as flex tracks and the waveform shows in the tutorial. I changed the view but still see no waveforms. Is this normal?

This is confusing me. Help or advice would be greatly appreciated.


You can see the waveform of samples assigned to a flex machine and also of a recording (recorder buffer).
Sure you have the right track selected? (Function + Yes previews the sample, check if audio plays when you hit Function + Yes from the audio editor)
Have you zoomed in to a part of the sample where there is silence?

In the audio editor you can select to view only the left channel, or only the right channel as well as stereo. (It’s under Edit -> Change view).
Do you have Stereo View selected?


Hi Schnork, it had to be something simple. It was the vertical zoom.

Thank you, greatly appreciated. Problem one solved. Let’s hope I don’t run into to many more. :ok_hand:


Nice try, but I can guarantee you will run into more as you expect. That’s just part of the journey. It gets better with time, but even OT veterans have their wtf moments now and then … :smiley:

And if there is something really strange and explainable happening seemingly out of nowhere try reboot the OT before searching hours for no reason.

1 Like