Weird 'linking' issue

I thought I’d solved it but I haven’t…

I’ve encountered a weird issue on my AK; it seems track one is somehow linked to the other tracks. eg.

  • when I mute tracks 2,3, or 4, track 1 also mutes (but not the other way around)

  • when I change the filter on track 2,3 or 4, it affects the filter on track 1

I’m sure if I’ve accidental switched a setting, or If my keyboard is malfunctioning.

Does anyone know what is happening here? I’ve tried the manual, but no luck.

Thanks in advance, it’s driving me mad!

No one else had this problem? Just me?

You have the auto chan set to the same channel as your track 1 (or similar, not in front of A4 right now).
You can change it to something different in the midi config channel settings.

if that’s not it, you could be sending the info to your DAW which is sending it back to the auto chan (set to 1?) or similar…

Either way, the fix will be in the midi channel settings found in the global menu (I hope :))

1 Like

Thanks dude. It was to do with the auto channel, and the performance channel. They weren’t set wrong in the AK midi menu, but I was doing something weird in Cubase.

Managed to fix it, thanks for the reply :slight_smile:

1 Like

ah OK, well, glad you sorted it out!

Sorry to bring this up again… but it stared happening again, and it wasn’t what I thought.

I’ve figured out how to stop it, but would really appreciate if someone could explain this!

What was happening - What ever track I’m on e.g. 4 is muted, when I mute another track. Same with the faders: e.g. I’m on track 3, and when I fade track 1 down, it fades 3 down as well.

So I figured it’s MIDI messages being sent back to the AK through my DAW, it happens only when on Auto Channel.

I can stop it from happening by going into MIDI Port Configuration, and deselecting ‘Receive CC/NRPN’

That has stopped the weird linking behaviour, but now the AK won;t be able to accept automation I make in my DAW.

Can anyone explain this, has anyone had this problem? It’s really odd…

No one having this problem?

Tell us what MIDI connections you have set up to the AK, and tell us ALL the settings you have in the MIDI SYNC, MIDI PORT CONFIG, and MIDI CHANNELS sub-menus under the MIDI CONFIG page, and we can probably advise on how to fix your problem.

Thank you, help would really be appreciated

Clock Receive - tick
Clock Send
Transport Receive - tick
Transport Send
Prog ch receive
prog ch send

Turbo Speed
Out Port Func - MIDI
Thru Port Func - MIDI
Input from - USB+MIDI
Output to - USB+MIDI
Output ch - Auto ch
Paramater Output - NRPN
Encoder cfg - int+ext
Joystick cfg - int+ext
keyboard cfg - int+ext
receive notes - tick
receive notes/nrpn - tick
live rec on trk ch - tick

track 1 channel - 1
track 2 channel - 2
track 3 channel - 3

track 4 channel - 4

track fx channel - 5

track cv channel - 6

perf channel - 8
auto channel - 9
prog ch in ch - 14
prog ch out ch - 15

This problem happens when my DAW (Cubase or Reason) is set to the auto channel AND when it is set to an individual channel.

e.g. I set my DAW to channel 1. TRK1 will mute when ever any other TRK is muted. The lights go off at the same time. The faders work the same, as if they are linked.

If on auto channel, it happens all the time: Which ever TRK I’m on, it will mute itself when I mute a different track.

1 Like


MIDI SYNC settings are fine. MIDI channel settings are fine.

You didn’t tell us what your MIDI connections (cables) are. Is it only the computer and AK that are connected together? Are you using MIDI over USB or MIDI through the DIN-style MIDI ports?

I don’t use Cubase or Reason, so I don’t know what “when my DAW is set to the auto channel AND when it is set to an individual channel” means. Hopefully a friendly DAW expert will stop by and see an obvious solution.

Hi, thanks for replying.
This is happening when the AK is just running MIDI via usb.

Regarding the DAW; when I create a MIDI track, and I allocate this to the same channel as the AK auto channel i.e. 9, or to the same channel as the AK track i.e. 1 - 4

In any DAW, when you create a MIDI track/lane, you assign it a MIDI Channel to correspond with your external gear’s MIDI channel. You can usually choose ‘any’ or ‘omni’ which will accept any channel. This doesn’t work in my case - I still get the ‘linking’ issue.