Weird Plays-Free bug?

Has anyone else noticed that after you start the Octatrack, if you start a Plays Free Midi track without running the main sequencer sometimes the Octatrack spits out garbage CCs? Like different values and not even the CCs that you have set.

Work around is to start the main sequencer first. Project keeps having the bug tho on every start, even after saving and reloading the project.

I’m mainly just posting to complain about having spent my night trying to track down the issue. Thought was a bug in something I coded up myself, only to find it was actually the Octa…

Could you check with a software midi monitor?

1 Like

Yea I did, I had only my 1 midi track on and used a usb hub. It was sending ccs on the channel that were not selected in my octa.

Usb / midi din interface you mean?
Could write more precisely what is sent, and what it should send?

1 Like

I made a test with a midi track, channel 16, 1 note and 4 CCs. Play free track, sequencer stopped, appently no problem (midi monitor checking).

Other things missing to replicate your issue?

1 Like

Midi plays free has a bit of a buggy history. Don’t remember this particular thing happening but maybe my gear was just ignoring those rogue ccs.

Anyway just to say make sure you’re on latest OS because things got fixed in this area (and not mentioned in release notes)

Feeling your pain on the time spent pinning things down. I’ve been there!!


Known bugs concerning play quantized, that’s it?

It was midi plays free DIRECT rather than quantised. Really powerful now that it works.

Another thing that seems to be fixed is on the audio side where you have a neighbour as plays free direct. Great for triggering mini fx sequences but used to cause freezes. (In my experience - undocumented!)

Take that back - I just got the freeze! :drunk:

1 Like

I call it the ‘yellow freeze’ - first trig stuck at yellow LED, sequencer not running, input LEDs frozen at whatever level at the time of freeze. Hello old friend! :yellow_heart:


Are you Mister Freeze? :slight_smile:


For my issue it only happens immediately after turning the unit on, before pushing the main play button at all. Also I suspect that my copy/pasting of midi tracks earlier on in the project may have created the “junk” midi data that is being picked up by plays free. Its not completely random, it looks like old CCs that existed on that track.

Ghost midi data ? :ghost:
I had weird things changing parts too.

If you find a way to replicate, tell us.

I’m still grappling with this. The phantom CCs are being sent even by a midi plays-free track when it is first played. My initial fix of starting the main sequencer first doesn’t actually solve it.

Switching to an untouched part/pattern in the same project didn’t fix it either. Something behind the scenes has decided to hold onto old cc #s to send when starting the playsfree sequence for that track. What did fix it was creating a completely new project.

I’m at a loss for what I did to get my project into this state in the first place. I’ve done a fair bit of copy/pasting of parts/tracks/pages so something in that may have gotten it into a bad place. I’m concerned that this new project will get stuck in this again. I’m hoping that I can get my material off the old project with some bank-copying or octaedit, because otherwise I may just have to let those sequences go.

Note: I also tried turning playsfree off and back on for the track. Did not resolve the phantom ccs sending when playsfree was re-enabled.

1 Like

Do you have OctaEdit?
If I have a little moment with a big curiosity peak I can try your project if you want.
I bought OctaEdit recently but I didn’t use it decently, my laptop having 1 third of the screen out…

Its ok, creating a new project and copy-pasting in the banks I needed (via my computer) seems to have made the problem go away. I was already getting rid of junk in my project so I was already going to do some of this anyways.

I learned an interesting thing about the octatrack midi while I was debugging this. It only sends the new CCs for a part change if the cc or value for a knob changes. In some ways this is useful in not sending out too much data to a synth. But it also means if you do a program change and the synth on the other end loads a bunch of new params, the values you have set on the octa may never get sent.


Really important to know when debugging / testing. I’d like an option for that, be able to send a midi message when I want. There are several ways to reduce midi data stream, especially lfo hold parameter.

1 Like

I’ve run into this bug again with midi playsfree tracks sending junk data. I seem to be able to work around it by following this procedure:

  • Start octatrack
  • Play main sequencer
  • Play all plays-free tracks to initialize them correctly. “junk” ccs are not sent

This also seems to work:

  • Start octatrack
  • Play main sequencer
  • Switch to different part (I did this via changing patterns)
  • Switch to part you want to use

This only seems to be needed once on start-up to get to a good initial state. I’ll update this topic if I run into more problems.

1 Like

Thanks for workarounds! I hope I won’t be concerned. :wink: