Wierd memory issues with A4

So I am getting pretty frustrated. I keep getting issues with saved stuff. I am pretty paranoid about loosing data so I always save kit, tracks and patterns etc. Anyway, I had a really nice track going for a while with the OT in charge. Then I went away for the weekend and took the A4 with me. I came back plugged it all back and bam my kit has changed. The track sounds are all screwy. It’s hard to say exactly whats changed but what appears to ahve happened is that the midi that was recorded on the A4 T2 is suddenly on T1 and the oscilator 1 on T2 seems to have been set to -63 on tuning (I think thats the case I don’t remember all the settings of the patch, thats what the save function is for). The OT has audio to CC off.

You know?
It happens to me (-63 OSC1 pitch on T1) too!!!

i dont do anything on OT, but this happens only when the OT is on (audio cc out off like you)

OT is the midi master using a thru box.

Reloading the kit does work for you? here it’s ok

Reloading the kit didn’t work this time but I also hit yes + kit by mistake instead of function+kit the second time so I can’t try reloading again lol.
It’s really frustrating, for me it seems to happen when I disconnect and then reconnect to the OT.

Backup your stuff and then try to reproduce it. Write down each step you take until the bug happens. Send a bug report. I guess there’s no other way to track this down and/or rule out user-error.

An alternative approach could be to hook up a midi-monitor/logger to your OT and see if the OT sends out CCs/nrpns despite its midi filter settings.

i had an A4/OT combo issue recently that was borne of having them bi-directionally wired in Turbo mode - even though the OT was not receiving transport, it was transmitting the note information from the A4 mini keys equating to transport commands back to the A4, so the A4 sequence got restarted when i hit the b key, the OT sequence was not affected (due to settings), but it still resent the rcvd command out the OUT port strangely ! i haven’t heard back from hq yet - but check the midi plumbing too

there was a previous forum issue with regards to a spurious cc command affecting the fine control of an a4 param, this was down to a parameter spuriously reacting to a cc message which was one part of a valid nrpn pair, it meant that the affected param could be partly and incorrectly targeted, but i thought this got fixed - anyway, the point was to look at the back of teh pdf to see which midi commands are connected with the fine part of osc1 and try to work out if they could be coming from anywhere in your setup,… of course, it also might be a gremlin, but as mentioned above, best to be methodical

i had the same issues with OT and A4. all i did is to disable the “send cc” in the octa menue. since then i have no more problems


Sorry for my english, i’m belgian.

I have exactly the same kind of things with my A4/Octatrack combo. I was really annoyed because i loose some work, just because of this, and like you i became a bit paranoiac, saving everything all the time. Today i find how this is happening with my stuff.

When i’m on the screen of the Octatrack where i can manage my thru machine, on the Playback screen, if i want to change a parameter InAB or InCD, it happen the same thing than the original poster. Osc 1 and Osc 2 of my first and second track on the A4 are lowered. My OT is the master.

I have to reload the kit to be able to work again. At first it was annoying because i didn’t know how to repair this. Now i try to be careful, but it’s still bothering me! I’m happy to see someone speaking about that, i thought i was alone.

I’m a bit lost with the midi signal out of the OT, i have to try all the possibilities to see if something can stop that annoying thing. I really need to find a solution! At least, i know how this is happening.

Edit : I loaded the “weird project” to try things. It happen only with the “INCD” parameter of the Playback page on the OT, where i have a Thru machine. If i want to change it, the Filter 2 Frequency (track 1) is lowered to 0 instantly. Weird because yesterday i think track 2 was affected, not today.

I’ve also noticed a few mystery changes… Go to bed with after really tweaking a track and power things on the next day and everything sounds ‘off’ or ‘different’. I chalked it up to me doing something wrong somehow even though I remember saving the project before powering off even.

It hasn’t happened to me too recently, but I noticed two things that I suspected:

  1. Accidentally bumping the crossfader on the OT and for some reason, some midi params may have been set on the scenes and causing issues. (maybe also why disabling send cc helps)

  2. Accidentally using the same kit on another patten and changing things up without realising they affect the kit globally (very newbie error on my part).

I think this must be a bug
Since i updated my sounds keep jumping octaves
Also when i change the pitch of sounds on the OT - this also changes sounds on the A4 (this didnt happen b4 the update)

All very well to disable CC’s, but i need them to midi sync the transport/pattern changes on all 3 boxes…

Anything else that can be done?

i have the same issues with MD and A4

the problem is the MIDI setup of both machines

you have to be very careful to the routing

[li]is send/receive active[/li]
[li]which midichannel is base[/li]
[li]which midichannel for cc[/li]

otherwise one machine can easily destroy patches of the othe machine.
that happend to me so often that i made different setups in the global menu for each machine.

at the moment i setup both to be clock master AND slave so i can connect them either way and the one that has the midicord in the out is always the master

and secondly i put the midi base channels on the A4 on 10,11,12,13 and on the MD on 5-8

as soon as you seperate them and dont let them react on omnimidi messages the problem should be gone

at least for me

just never ever touch this globalslot and make a new one for each setup even if it SEEMS to be the same situation :slight_smile:

thats a part iam still working on cause iam lazy hehe

Last night it happened to me. I upgraded the A4 to OS1.1b a few days ago. I’d been working on 2 patterns for a new project, being careful to save everything - at the pattern, kit and project levels. I powered up and the kit on one of the patterns had changed. Track 4 had a default sound in it, although all the trigs were there in the track playing the wrong sound. And Performance C config had also been wiped - even more annoying because that was bespoke and not just a selected sound!

Is this going to mean we can’t rely on our kit to have all our ‘content’ ready for a gig??? Or did we all have it coming for installing a beta of the OS?

It’s not a beta, the b is just a revision. If it’s actually a bug it ought to be repeatable and therefore verifiable and fixable. Try to replicate it with bogus patterns and send in a ticket if there’s a repeatable issue !

I had a similar issue…

  1. Was in a project working on pattern and kit where I had customized the sounds.
  2. Saved kit, saved project, and switched to another project.
  3. Turned A4 off. Turned it back on about an hour later.
  4. Loaded project from step 1. Kit no longer had customized sounds. All custom sounds from the kit were gone and all sounds were default.

Tried to reproduce a couple of times but couldn’t.

Been a bit busy to test it out but seems some people are having issues with audio to cc which definitely isn’t the case here. I’ll try again later and maybe send a bug report but seems the elektron guys are still on vacation.

Ive been getting some memory issues. A4 is resetting after each power down. At first I thought it might be to do with this unusual prolonged hot spell we are having in the UK. But its not the case. Any advice?