~30ms delay in recorded Digitakt Overbridge tracks


I wanted to share an issue I’ve had and see if anybody else has had the same issue, or might have found a solution.

I use Overbridge to record Digitakt individual tracks in Ableton, with the Digitakt midi tracks sequencing external synths, which i record through my mixer’s direct outs into my audio interface. I am not sync’ing the Digitakt’s transport to Ableton, am using the DAW just as a multi-track recorder. The problem that the recorded individual audio tracks from Overbridge are about 30ms behind the rest of the recorded audio from synths, other drum machines sync’d to the Digitakt, and the stereo audio recording from Digitakt’s L/R main outs.

It is not a complete tragedy, as the lag has proven pretty steady at around 30ms regardless of tempo and CPU load, so i end up moving the Digitakt recorded tracks by that amount by hand after recording. It is nonetheless annoying, would be great if it could be avoided.

I am running Ableton 10.1, Overbridge 2.019, Digitakt OS 1.11. The “delay compensation” option in the Ableton drop down menu is checked.

I have filed a support ticket with Elektron on this but no success. Has anybody experienced this? Any success in resolving? thank you.


I experienced this with OB1 and never was able to fix it. It’s been awhile since I gave up on OB all together so I may be wrong but I think they said it’s inevitable or something.
It made using it too much of a PITA for me so I bought a Usamo and just record individual tracks with far better results.

I just purchased a DN and a DT so I may have to (with great trepidation) jump back in.

It probably has to do with the driver error compensation amount. If you’ll go to the help menu and click show all lessons there will be one toward the bottom of the list about it. There’s a project that will walk you through the steps to find out how much to compensate for and shows you what to do. It’s pretty straight forward and afterwards everything should line up fine. There’s also a YouTube video on it by sadowick or Ableton themselves. Maybe that will help:)

1 Like

I think @gross is right. Adjust the driver error compensation til you have an overall latency of just over 0ms:


thank you so much @craig and @gross i will try that tonight.

1 Like

No problem, I had a similar situation and this fixed it👍

@gross @craig it worked! though to get the Overbridge recorded tracks to match with the recording of the L/R output i had to increase driver error compensation to the point that the overall latency is a negative value. Not really sure how that affects everything else, at least in the quick recording experiment i did yesterday all lined up, including hand played instruments, so…more experimenting over the weekend. Thanks a lot for your help on this, it is great to have a community like this one.


Glad it worked. The real bitch of it is if you have to adjust your buffer size because of too many plug-ins etc etc, you’ll need to adjust the other settings again. It’s confusing at first but a useful tool to have.

1 Like

Awesome :slight_smile:

1 Like

Now all that is missing from my quest for a 100% struggle free setup is Elektron to raise the output of Digitakt recorded tracks to a more workable level in the next OB update! here’s to hoping…

1 Like