Analog Four Ableton Latency Problem

My current setup is Analog Four>Scarlett2i4>Macbook w/Ableton Live 10
I’m not using Overbridge or Usb Cable.
So the problem is I’m getting this latency problem (input:2.67ms , output 4.68, buffersize:256)
When I lower the buffersize it makes jitter noise.
I have to record audio in 96khz, so I can’t change the sample rate to reduce latency.
Anyone have suggestions??

There are sooo many threads on this subject to look through. There really isn’t a good answer. Maybe adjust the driver error compensation, but you are headed down a rabbit hole. I just record my music into my DAW and work in the DAW separately.

These are also an option

So you mean you record audio, warp, and quantize the audio?

Yes. If it’s beat driven, I have a kick (even if the piece doesn’t have beats in it I usually have a one bar pattern with four beats) on the first step and I warp from there.

Do you mean crackling noise? As if the audio is breaking up? You are probably at the limits of what your computer and audio interface drivers can handle. Recording at a higher sample rate requires more processing power as well.

Your latency isn’t horrible as is.

You may be able to reduce the buffer by keeping your virtual instrument and fx use to a minimum in the project. You can try freezing tracks that use virtual instruments and/or virtual fx. Then try lowering your buffer again.

Check to see if you have plugins that generate latency. If you hover your mouse over the Ableton external instrument (or other plugins) you’ll see that it adds latency to the project.

You can also try turning off delay compensation in the options menu of Ableton Live. You may end up with out of sync parts of your project though depending on if the latency is real and needed or not.

If you still get crackling, you may need a more powerful computer and/or an audio interface that has lower latency drivers (e.g. Presonus Quantum or other low latency Audio interface).

+1 on this. Not a lot of people notice <5msec latency, so maybe it’s more than that because of a plugin. Just as an example, Unfiltered Audio Spec Ops can add 100s of msec of latency with certain settings.

1 Like

I assume you are monitoring the A4 through Ableton? If so, use the External Instrument device, and set your hardware latency to where a recording looks tight on the Ableton grid. Turn on Delay Compensation in preferences. You are effectively delaying the live set to match the input latency of the A4. It should sound well synced now.

Any crackling or dropouts are a totally separate issue. Good advice on that, above.