Analog Four MkII Malfunction

This morning I had a malfunction with my Analog Four MKII. I was switching on my music gear, and when I switched on the A4, I’m not certain it ever booted correctly. I wasn’t looking directly at it, and then I was switching on other stuff and then went into the kitchen to make some coffee. About a minute later, I heard some strange sounds coming from my monitors, and when I went and checked they were coming from the A4. Definitely not synth oscillator sounds, it was more like electrical/electronic/RF interference sounds, modulating sine wave sounds plus static and rumbling. It was fairly loud, or at least not faint. The A4 was showing no lights at all, completely black OLED screen. I turned down the volume on my mixer and switched the A4 off and back on, nothing, still no lights or any indication of power or activity. I did this a couple of more times, still nothing.

I have the A4 and several other music devices connected to a powered USB hub, and 99% of the time everything operates perfectly, but every once in a while I’ll have a problem like a device not being recognized, a time or two Maschine MKIII has failed to boot properly. Once right after I purchased the A4 this happened with it and the unit hung on the boot screen (showing firmware version). Disconnecting USB and restarting solved the issue in that case, so I tried that this time (as well as disconnecting 5-pin MIDI), but still nothing. Finally, I disconnected the power adapter from the AC outlet (power strip) and waited a minute, and this time the A4 rebooted correctly when I powered it on. The USB and MIDI were still disconnected. I tried cycling power off and on several times with USB and MIDI reconnected and it’s functioned normally. I ran the self test program and no errors were reported. Because I was having a bit of an “Oh shit” moment, I forgot to ever turn the volume up again while it wasn’t booting up to see if it was still making those noises.

I’ve sent a support ticket in, but I’m just wondering if anyone has experienced something like this. Could it be USB or a faulty power supply? The unit is only seven months old, but my worry is that there may be some slow motion hardware failure that won’t fully manifest until it’s out of warranty.