AR mk2 wont connect to overbridge

Hi, i recently purchased a used AR mk2. Now i’m trying to connect it to overbridge. But when i plug it in nothing apperas to be connected in the OB application. I tried reinstalling OB, upgrading OS to 1.5 but nothing seems to work, and OB mode is selected on the AR. What could i try from here? and is there any obvious things that i have overlooked?


Im not using overbridge but one thing comes into my mind:

In PORT CONFIG menu make sure that you have selected:



Can also select " USB + MIDI" but in this case USB speed could be limited.

Same thing is happening to me and I tried all of the options listed above. Using Overbridge 2.0.30 and Analog Rytm 1.50 with a MacBook Pro and Sierra. Also, I shut down the Overbridge Engine once in an effort to troubleshoot and even after uninstalling and reinstalling Overbridge, the engine hasn’t reappeared; I only have access to the control panel. USB Config is set to Overbridge, Midi Config IO has been set to USB + Midi and just USB. Nothing has worked so far.

This is an older MBP with standard USB 3.0 ports, not USB C. I allowed Overbridge with my firewall settings and no notifications have appeared under the Privacy and Settings control panel.

I’m using the USB cable provided with the Rytm Mk2 and plugging into the MBP directly, without a hub.