Arp not triggering semitones. Bug?

I’ve run into a problem sequencing a Bass Station 2 with the Octatrack arp. In the pattern I start with a 3 note arp, Root note C4 note 2 + 3, note 3 + 5, No probs. Then a change to C4 note 2 + 3, note 3 + 5, note 4 + 10 no probs, then C4 note 2 + 3, note 3 + 5, note 4 + 9, but the fourth note plays a whole note lower, ie.+ 8! I tried with note 2, then note 3 deactivated and same thing happens! I’ve got the pattern on half speed of main tempo. Arp and latch on the BS2 are deactivated. Is this a bug? Has anyone else had this problem?

Are you sure of the notes you want to send ?
Where is the semitone ?
If you’d give the notes names maybe it would be easier to understand your problem.

1 Like

Sezare, thanks for the reply

C4, D# 4, F4 and the fourth note is set to trigger A (5), (C4 +9) but instead instead triggers G# (4) -

The previous 4 note arp chord in the pattern - C4, D# 4, F4, A# 5 plays correctly.

Further clarification

When I trigger C4, D# 4, F4, G# 4 it plays correctly

When I trigger C4, D# 4, F4, A# 5 it plays correctly

When I trigger C4, D# 4, F4, A 5, it plays C4, D# 4, F4, G# 4

Ok it’s clearer. Never had such weird behavior.
Can you use a midi monitor such Miditest (PC) to check what you really send with OT?

Same behaviour with same notes and different root note ?

1 Like

I would have to install miditest, but as you see above, he root note is the same,

I tried aetting a different root note F3, and the fourth note triggers a semitone lower as it should.

Try to send these notes but with D#4 as root note…

1 Like

Did you turn of the scale quantise functionality?


The same: still getting G# instead of A, Tried setting the A an octave higher, still get G#

I forgot that, I don’t use it, it should be the explanation. :slight_smile:

1 Like


If anyone is looking at this thread with the same issue, it’s KEY - OFF in the arp setup

Many thanks Kreis, and Seazare. I really appreciate your help.