Arpeggiator external midi keyboard

Hey everyone,

i have my analog four now since a couple of weeks and I absolutely love it! I have one problem though: I have a nice arpeggiator line from the a4 integrated arpeggiator. The problem is that I can only record this as audio into ableton, because the arpeggiator only works when you use the mini keyboard, but not an external midi keyboard. Is there any way to record the midi from the a4 via usb? Or can I set up my external keyboard that the arpeggiator still works with it?

Thank you guys

You can use an external keyboard and play a track on the A4 with the arp activated.
You cannot send sequencer midi data out of the A4.
You could use Live’s audio to midi converter to take the recorded audio and turn it into midi notes within Live.

1 Like

Hey thanks for the reply. How do I need to set up the keyboard in order for it to go through the arppeggiator? because if I play my keyboard now and the arp is activated it still doesnt engage. I already tried using the auto to melody function, but it didnt work so well.

Using the auto channel should have worked. I set my MIDI out channel of my external keyboard to A4’s auto channel and it triggers the A4’s arp.

1 Like

I tried that andt it didnt work for me! I use ableton and overbridge in between. All I want is program some chords in ableton and play the midi back so that the A4 plays the arpeggiator.

1 Like

Ableton Live does this weird thing, if the playhead is not running, it clips midi note data coming in.
Live’s playhead has to be running for midi notes from an external source to work properly.

Other than that, for your keyboard and Live “clips” to play the A4, it should simply be a matter of setting the Midi Tracks input to receive from your keyboard, and sending the output of that Midi Track to the A4.

Does it work without the arp?
Are you able to play chords on the A4 the way you want just without the arp?

Live clips play absolutley fine back. I can record the midi from either the A4 or the keyboard and live saves them as midi clips. Playback works great too, but the problem is that it only plays the chords even though the ARP is turned on. When i play the same chords then on the A4 mini keyboard, the ARP works.

I use an external keyboard with my A4 and I guarantee I can use the ARP.
This there must be something going on…

First have you tried to play with the keyboard directly connected to the A4, removing the computer of the equation ?

1 Like

Yep, external chords arriving sequenced or human playing an external keyboard will work that arpeggio

make sure poly is not stolen elsewhere - and ensure arp legato is off, it may confuse things

but otherwise this is more a Live usage issue

I tried on auto and it’s fine, it seemed to be dead on the direct channel which makes no sense - it somehow locked the track out when I changed the midi channel whilst it was playing - it needed a sound reload to tidy it up - so it was a little inconsistent - maybe try a kit reload once in a while and I think avoid changing midi channels dynamically - this may hang notes and lead to unexpected behaviour - that was my experience - though it doesn’t explain why you hear a chord but no arp even whilst it is on

I just cant seem to figure it out. I checked all the midi channels in and out. I record a clip into live (a chord) with overbridge. When I play that same chord on the a4 mini keyboard the arp works perfectly, no problems at all. But when ableton plays the chord back it just does not engage the arpeggiator. I am just using one midi channel with the OB plug in and a usb chords.

I didnt hook up the midi keyboard to the a4 directly yet, because i want ableton to play back the chord sequence while I teak the parameters. I also turned arp legator off and the channels are auto.

okay wow. I feel like a total dumbass now. When I play the clip from a different midi track other than the OB plugin, it works. Also I am on auto channel (8) there.

Thank you so much for your help guys!


However, one more question though: Is there any way to automate the arp type in ableton? OB does not include the parameter and when I click the midi learn function and move the knob, nothing happens.

Not lockable in the internal sequencer

It’s also a part of the Track, not the sound/kit, for which all the midi control is set up - so basically you need to turn that encoder

Good day fellow nerd folk! I just joined because I hit a wall with my online searches, and all good threads are resurrected, no?

I’m in Live trying to use a midi track to playback the arp on my A4. Auto channel is set to the same channel (1) on a fresh MIDI track - no overbridge loaded. I get playback each time a new note is triggered, but still no arp. What gives??

Does arp work when you use A4’s keyboard ?

Dears I can’t figure this out. Arp works with the mini A4 Keyboard. Either Push nor an other external Keyboard trigger it. If I switch to ARP ON only the mini A4 Keyboard works, the other two go silent. If I switch ARP OFF same thing until I press a key on the mini A4 Keyboard and then suddenly the external Keyboard work again. Reinstall OB or Firmware reset won’t work either. I really want to be able to play the ARP using an external Keyboard. Using an extra Midi track and sending the midi to Channel 1 for example don’t work either, same result. Please help, thanks



Anyone figured this out? I did send a description of this issue to Elektron but no answer yet.
I would like to trigger the arp with external midi data and it does not work. (it does when I use the A4 mini keyboard)

1 Like

just tried it here with overbridge, seeing the same as @thoughtless
it’s a bit of a mess:

external note input does work, until you turn on the arp.
at this point the note input still works (push2 via ableton here) but won’t arpeggiate.
try the A4 built-in kb to test (the arp works of course), then try the external controller again - note input has either stopped working completely, or only plays one pitch, no matter which note you press on the ext controller.

turning off arp returns control again, but still no arp. yeesh…