Beatstep Pro and Model:Samples octave (or pitch) problem

As you might know on Beatstep Pro, after Firmware Update 2.0.1 there is a possibility to assign the each pad to specific Midi channel. So I did it, but whenever I play the pads on BSP, all the samples
on Model:Samples are 2 octaves higher (or pitch +24). How can I change it? There is no such option as chancing the root note on the Drum mode section of Arturia Midi Control Center. Also I couldn’t change the default note of Tracks on M:S.

Do you need to use the drum mode? The two other sequence modes have octave shift functions.

I think you need to change Seq. Trans. Center Pitch to C3.

Its in the Trasposition section of the device settings.

If I remeber right, this was a setting I had to change to use the BSP with my Subharminicon.

Each drum track (kick, snare, hihat etc) has to have different midi channels. And it is only possible on the Drum Mode on BSP. But it only triggers one note when you assign a Midi Channel to a specific Drum Pad.

Also I am using the Sequences for 2 different Volcas. So I don’t have empty slot. Plus theoretically this is the correct way to organize them but either Arturia or Elektron doesn’t allow me to do that.

Unfortunatelly this is also a setting for Sequences. I am talking about Drum Mode here. What you are saying is not changing the default note of Drum Pads but thanks anyway.

Ah, I see. I wish I knew the solution.

Shame there doesn’t seem to be a way for this to work … otherwise that firmware fix looks ideal for M:S