Buttons gets stucks MKII

Anyone has a solution for buttons who keeps lagging/hanging on the case. In other words: when I press a trig or other button, some buttons won’t return to their original state. I need to manually “pull” the from under the hardware chassis.


Many threads here below - Also happens on my DT - didn’t think it would be such a pain in the ass when I got it but it annoys me more and more and more and… Impossible to use in a live situation.


I simply pressed them a little harder in the opposite direction…Worked for my Dt…

I am sending my OT MKII to the Sweden workshop this week for exactly this issue.

I have 2 buttons affected. Trig 1 and FUNC.

Cannot live with this, has to be solved. Support was very helpful and replied within an hour after filing a support ticket.

You guys need to use the machines more, my DT had this issue on two buttons and within maybe 5 hours of use it stopped happening. Although if it’s still happening after a good break-in then yeah I guess that’s not ideal, better to send it in.