Digitakt 1.06 : Bug reports

Firmware 1.06 is now released, discuss here

You encountered something wrong in OS 1.06 and want to check if others can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se if they have not already been confirmed below.


It seems like the OS update is hanging up? Using Transfer, it looked like the file sent imediately and Digitakt responded w ‘receiving’ but it’s been like that for about 10 min now. I haven’t tried from the early startup menu, but at this point I’m scared to turn it off.

Anyone else having this prob?

Still not loading samples into slots when copying a sound to the pool.
Soundlocks useless so, cause it just change soundparameters basicaly

The last few times I upgraded, it seemed like Transfer was doing nothing but my Digitakt displayed different messages. The whole process for me wasnt more than 2-3 minutes, if not less…

Maybe try a different usb cable and usb port? Could be something like that.

I have the same issue, I think the process is stopped while receiving the uptade and nothing is happening at all

Make sure there is no midi cable plugged in.

I’m using the Elektron USB cable and no midi cable is plugged, I keep having the froze in different places with other USB ports, does anyone succeed to install it?

For OS upgrade, I always use C6. Good old technology that doesn’t die :slight_smile:

Be sure to have both MIDI IN and OUT set to USB only !!

EDIT : @marshallwatson I removed the duplicate, it’s better to keep everything in the right place :slight_smile:


Looks like it was having midi set to usb+midi was the issue. Thanks!


The Settings/Project/Manage Project page is buggy here:

  • Press Yes to ‘tick’ a project name – the tick doesn’t appear next to it…
  • Press down arrow – the ‘tick’ will appear now, but the following project name underneath is always skipped.

The Settings/Samples page doesn’t have this issue

Deleted samples are still shown in the currently loaded project here.

I deleted 3x unwanted samples that i’d previously transferred to the DT, but they’re still shown in the Assign page and via the D encoder in SRC page. They don’t disappear from the list until the DT is rebooted.

Had the same with the transfer app and it worked with C6 immediately

Did the upgrade with the transfer app. I got “OS UPGRADE SUCCESS! REBOOTING” but it’s not! Should i restart or?

edit: Manual boot went ok!

18 posts were split to a new topic: Off topic posts from bug reports thread

I get the same.

As far as I can tell the only thing still broken on the update is the INF length retrigger that doesn’t work, and people say double tapping stop with a midi loop still crashes the machine. Aside from a couple of minor interface issues all else seems good.

1 Like

Anyone having trouble with “undo track clear” and “undo pattern clear”. Seems to work intermittently here. Will someone try it a few times for me?

EDIT: Undo works fine for me when playback is stopped but it doesn’t work if you are in play mode. Can someone else test this for me before I put a ticket in?

1 Like

happens here same as for you.
Can only undo clear when not in play mode
Gonna have to be super careful on those copy and paste commands until that’s fixed.

Rectification. It actually works. It was again just because unsaved projects under the new OS.

1 Like