Digitakt + iPad + CCK issues

Hi I recently purchased a Digitakt and since the latest update I got an Apple CCK (USB 3) to use with my iPad Air (2019).

I’ve been messing around with it for a few days with Synth One and Moog Model D in stand alone both were working great apart from the iPad audio seemed to stop and I had to keep unplugging the USB cable so Digitakt could pick it up again.

Tonight I tried AUM for the first time. The Digitakt froze a couple of times. Tried pressing FLR, AMP start stop etc nothing would happen. Tried turning it off and on still kept freezing. After that it seemed to work ok until AUM completely lost connection with it. Digitakt was missing from the list when I tried routing the Midi Control In AUM. I tried different cables nothing would happen. I tested in Synth One and Model D nothing again. :sob::sob::sob:

I then tried connecting my iphone that seemed to work ok. Then after a while I tried the iPad agin and it seemed to work without any further problems.

Has anyone else had this issue? I can’t tell if it’s the firmware in the Elektron being buggy, or wether it’s the iPad or the cable or CCK?


All I could say is that for the last days I’ve been using an iPad pro with a USB C hub, not an apple one, and the Digitakt and it has worked great, so I’d assume it’s not a problem with the Digitakt, or at least not with the way I use it which is mostly audio in/out, and clock in or out (tried both)

I have been having issues with the Digi crashing too.

I am connecting the Digitakt to a iPad Pro and using AUM. No hub and all official cables/adapters.

That being said, it does mainly work and is a great pairing. I am really hopeful we will get multi outs to the IOS at some point as this would make it perfect.


Hi thanks for your reply, in the main it is working for me too and it’s brilliant went it does.

Apart from the Digitakt freezing I can’t determine what’s causing the sudden loss of audio from the ipad - weird!

I wondered if it was something to do with the clock.

Good luck fixing it btw!

if the digitakt receives too much/ certain midi information, it can crash. i remember this discussion about it regarding the midi loop back trick…

you could maybe try avoid sending unnecessary midi data to the device, but it is just a guess… for example dt sends clock to ipad and the app sends it back to dt, unintendedly…

Not sure precisely what issue was conveyed, but this is a good sign:

From: https://forum.audiob.us/discussion/39515/an-ipad-musicians-dream-came-true-digitone-and-digitakt-are-now-class-compliant-audio-interfaces/p2


The Digitone has a known issue with the new firmware and Class Compliant audio. Audio will drop even though the iPad is still connected and using the Digitone as an audio device. Tickets are in and Elektron is aware of the bug.

I don’t know if this is the same issue on the Digitakt as I’ve not been looking in the Digitakt bug thread but it’s definitely a bug on the Digitone.

As for the freezing, is the CCK you’re using the one that also does power delivery? People seem to have a more stable connection using a powered USB hub to connect. While the Digi boxes obviously don’t need to draw power from the iPad while connected sometimes the iPad will flake out if you don’t use a powered USB hub in this situation.

Food for thought :slight_smile:

good point, i think the usb3 cck the OP uses, has a power in also… maybe worth trying it…

There’s a new 1.20A firmware update released July 1 that includes a fix for this: https://www.elektron.se/wp-content/uploads/2020/07/Digitakt_OS1.20A_readme.html

I wonder why it’s not called firmware 1.21?

the A usually signifies a bugfix version (no added features)


Hi is anyone else still having issues connecting an iPad to the Digitakt since the latest update 1.20A.
I had the two devices working fine then all of a sudden AUM lost connection to Digitakt. I’ve tested on my old iPhone 6 and everything works fine.

The iPad is a 2019 iPad Air running iPadOS 13.5.1.

Really annoying since it was all working perfectly the other day. Just wondered if anyone else is experiencing the same issue?

haven’t tried it since the update but, just to understand better… does it disconnects as in AUM changes the input to the microphone? or it just cuts the audio?

I’ll have a look later, I have latest update and ipad mini 2019
I havent used them since updated to last one