Digitakt recording in Ableton Session View through OB aborts instantly


So I just got my Digitakt and love it so far. I managed to set-it-up in Ableton and can record in Arrangement view through Overbridge.

However, if I try in Session view it only records <1sec of each track, then switches to playback mode (see screenshots). I have tried many combinations of different settings but none seem to work.

Did anyone ever experience this issue as well? If so, any idea on how I can solve it?

On the DT, the settings are as follows:
MIDI config: clock and transport receive ON
Ports: out port func/thru port fun/input from: MIDI
output to: MIDI + USB
output ch:auto
USB config: Overbridge on, rest off


hm strange if only happening in session view ay - could it be something to do with one of the controllers? Seems a bit like a midi loopback issue but you’d expect to see that in both views.

I only personally record in arrangement view. When I’ve had loopback issues it’s generally resulted in nothing happening, rather than getting 1 second of audio - that’s the odd thing, not sure I have a good guess for that as it’s not even 1 bar

Yes that is the odd thing indeed. All the other controllers are turned off at the moment so I don’t think that it comes from there.

Note that I had it in arrangement as well, but I solved it by removing all midi settings in Ableton.

I have the impression that I messed up one part of the set-up but I can’t figure out what…

1 Like

I did just notice something in your screenshots actually - it sounds like you’re clocking from Ableton (which is sensible), but it looks like you’re receiving MIDI from your interface, not sending it.

Do you have the transport settings set correctly in the overbridge plugin? I think they just mimic whats on the device but something to check. I feel like there’s a loop somewhere.

Second thing would be to limit the MIDI on the takt to either USB/MIDI, not both, remove one from the equation, see if you can rule something out.

1 Like

Ah very good point, I don’t know why I had the MIDI in set up from my interface! I removed it because I am not connecting anything to my interface MIDI, but unfortunately that doesn’t seem to solve it.
(I forgot to mention that I am not using the Digitakt as audio interface, but I think that you noticed it already).

The OB is set to clock+transport, I think that it is what it’s supposed to be but I’ll try to play around with it. Also tried to change the USB/MIDI settings but no luck.

What is also very strange is that so far I didn’t find anybody having the same issue so I probably did something very illogical somewhere :sweat_smile:

Thanks for your help ! :slight_smile:

Found it!!! :smiley:

I noticed that if I only arm one track, it recorded normally, but it started messing up when arming several tracks. It seems that turning “Exclusive Arm” OFF solves it.

No idea why it works in arrangement view, and no idea why it enforces exclusivity even if I manually armed all tracks… But anyway it seems that it works now so I’m happy with it and ready to have an awesome week-end :stuck_out_tongue:

Thanks again!

1 Like

Ah nice one glad you worked it out, I wouldn’t have guessed that!

1 Like