Digitakt Step Seq not Automatically Advancing

I am new to the world of the Elektron Digitakt so just discovered the Step Seq Mode. The step seq does not automatically advance to the next step but rather i have to manually advance it with the arrow buttons. I watched several videos and even jumped in discord with a friend trying to troubleshoot it. I am using a new project and updated the firmware. Neither fixed the issue.

Has anyone experienced this or have a suggestion?

Are you on the latest 1.40B (released 2days ago)? There was a bugfix for the step advance marker not showing.

Yes, I updated it a day after it was released. I find it very odd that I am the only one having this issue. Has to be software because everything else works fine. I even tried unhooking all of my midi gear, rebooted into an empty project but still the same. very odd

Just watched your vid again - i see you’re in Step Jump mode so thatmight be something to do with it… ?

Pressing REC + STOP multiple times toggles between Jump and Standard mode. You want to be in Standard mode to not skip any steps.

But i can only recreate your issue with specific settings in Jump mode (e.g. 4/16 pattern length, trig length 1/4) but this won’t be the cause if you’re using a new default set. Best asking support really.

1 Like

I don’t have my DT with me so I can’t test this, but I think the issue is that you have to press and hold [FUNC] for auto advance to work. I got stuck with this too and gave up and then I saw someone else do that in a video and I had an ah-ha moment.

From the manual, which I just checked now:

  1. Press and hold [FUNC] and then press [TRIG 1–16] key to add a note trig on the corresponding track to the active step. The active step then automatically advances to the next step.


The step sequencer does not work when the USB cable is hooked up to the computer with Logic X running for some reason. If I unplug the USB and reboot it works as it is supposed to. I will have to investigate further or not use this feature when using Logic X. I run the Digitakt through and Interface into Logic X for effect chains. A bit disappointing but it is a Logic X issue.

Never really tried step record on my digitakt till tonight and it doesn’t advance steps in either standard or jump mode
Doesn’t matter if i use external keyboard or hold function and use the onboard buttons

Pressing right arrow will advance ok tho, that way is still possible to record as normal

Is this a bug? Am on the latest firmware and AFAIK everything else works fine
Does step record still work for others here in their DT with latest FW?