Digitakt usb into Akai Force = unsupported device / Solved!

I’m trying to connect my Digitakt(1.3) to the Akai Force(3.06) by usb and I’m getting an unsupported device error on the Akai Force… Has anyone else experienced anything like this?

  • The Digitakt works perfectly with my PC and OB/Transfer
  • I can get ir working using regular midi, so I can always do that.

I didn’t try connecting the DT to the Force before update 1.3, but I did find other people online that did get the DT working with the Force as recently as six months ago… so it is/was possible.

I’m just trying to figure-out if the update is causing this, or if it’s something else.


Is the Force a USB Host? Do you have Overbridge mode disabled on the DT? USB MIDI enabled?

1 Like

Midi over usb seems to work fine on my end but you need to have the Digitakt or Digitone in usb config in usb audio/midi or usb midi mode.

1 Like

Problem solved

@d4ydream … Thanks, you are the best… it’s been so long long since I’ve changed any settings that I completely forgot about disabling Overbridge mode in the DT

Have a great day


@AdamJay fixed!

1 Like

Does it do Audio over USB as well?

I’m not near my Akai Force to check… but, from what I remember it can’t stream audio to disk over usb yet.