Digitone Keys - pattern changes one cycle later than master device

Hi, my Digitone Keys (OS 1.31) needs one cycle through a pattern before it reacts to the change from the master device (RYTM mk2, OT mk2, A4 mk2 I’ve tried them all)

I’ve seen some posts on this subject but they were from years ago and had no solution or explanation.

Is there currently a fix for this? Or a workaround?


i guess you are using scale per pattern on your digitone keys.
normally ch. len(change length) should tell the dn when to switch patterns, m.len(master length) tells the pattern when to restart.
now after a bit of experimenting: i think as soon as you change the master length to anything other than the ch.len, the pattern switches too late. this is only if the devices is slaved, standalone it works fine.
this is a really frustrating bug because you can’t to any polymetric patterns. come on elektron, it’s been years!
if you don’t need to have the need for polymetric patterns, try to make ch.len and m.len the same length.

Hi catchy1, thank you for the reply. I assume you are talking about the screen after pressing FUNC+PAGE. I changed the ch.length to 64, same as the m.length. Ch.length was sett to OFF before. Now, after setting it to 64 the Digitone starts on the correct pattern, but requires two cycles before it changes to the next pattern. So, it changes to the second pattern when the master device is changing to the third pattern.

So, something is going on with that. But perhaps there are other pages in the Digitone to adjust here?

Logically, wouldn’t the whole “problem” of different lengths go away if I set the Length to “Per Pattern”? I tried this and it didn’t change the behavior, sadly. DT still needs an extra go on the first pattern.

huh… will have to do some tests later.
what pattern length is your master device set to?

Master device is A4, set to length 64 in normal mode. The whole chain is:
A4---->RYTM---->(midi out A) Digitone Keys / (midi out B) OT

All units are mk2. All units are set to 64 pattern length.

I have tried switching the Digi and OT midiports connected to the RYTM, so Digiis B and OT is A. Didn’t make a difference.

Does it behave the same way if you only have A4 OUT —> DN IN?

I’m wondering if the Rytm is interfering.

Something else occurs to me. It looks like you want MIDI Sync/Transport and PGM CH to pass thru the Rytm to the DN and OT As far as I know, only the Rytm’s THRU port can behave as a THRU, the OUT port does OUT or DIN SYNC. So your set-up is more like this:


I find it easy to imagine this set-up wouldn’t sync the DN in the way you hope, but I can’t say exactly how or why it would go wrong.

(Sorry, you have a DK, not a DN. Same stuff applies.)

Octagonist, thank you! I didn’t realize the A and B ports were different in that way. I does make sense and explains some other confusing results I’ve had when trying various combinations.

I’m gonna try connecting all 4 devices “in series”, midi-wise, meaning I’ll use only the thru port on each device,

Good luck. Let us know what you find out.

After some more testing, I now see that it is the RYTM that is causing this behavior. When I remove the RYTM and go A4---->OT—>DTk everything is fine and the patterns changes as they should in the OT and DTk.

When RYTM is the master device the problem is there again.

Is this a known problem with the RYTM?

SOLUTION: RYTM last in the chain fixes the problem. It can’t be the master and it can’t pass the Program Change message Thru to another device without the “1-cycle delay issue” appearing downstream.

Glad you solved it.

Have you discussed this with Elektron? Their customer service team will probably be interested. The problems mentioned before with scale-per-track and CHNG LEN occur on all the current devices and Elektron are working on fixes (they’ve claimed).

Out of interest, did you try the THRU-only method? Did the Rytm introduce the delay in every position in the chain? How do you have the auto-channel and PGM Ch configured on each device?

(I have an AR and OT. I’ve seen the scale-per-pattern problems and occasionally seen either my AR or OT go out by one bar, but it’s been inconsistent and hard to repeat. I have fewer Elektrons with sequencers than you so my setups are a bit simpler. I often, also, put the AR last, but more because of the way my synths THRUs and my workspace is arranged.)

Yes, having the RYTM last is a fine workaround for me.

Thru-only method: yes, if I understand that concept correctly. Only the first device (A4) uses MIDI out The rest of them are all getting their Sync and Pattern Change from the Thru port of the device ahead of them in the chain.

Question - does this mean that the settings for “send Program Change” is irrelevant? They’re all just passing on the midi in to the Thru port, so it should work even if they are set to not send. Mine are all set to send the program change, maybe that means it’s sending “double”? I’m gonna try altering that tomorrow.

As for wether the RYTM introduces the delay regardless of where it is in the chain - yes, but it only affects the units after it in the chain. (I guess this makes sense).

Maybe I should send Elektron an email about this.

UPDATE: Yes, turning off all the “Program SEND/Clock SENDe etc” on all devices except the master fixes the problem entirely. The RYTM can now be second in the chain, next to the A4 and no problems. I guess the “double signals” was messing it all up.

1 Like