Digitone not recognized by laptop/overbridge/transfer no matter what : (


I am having issues with overbridge and transfer not recognizing my Digitone device. I have changed cables, downloaded/reinstalled older versions of overbridge, restarted all my devices, etc. and cannot seem to figure it out. On my new laptop I am running macOS catalina v10.15.5… have reinstalled overbridge to an older version v2.0.17.13 Beta, and my Digitone is running OS 1.21…

PLEASE help me figure this out! thank you.

Current digitone fiemware is 1.30a, current overbridge is 2.0.39, current transfer is 1.2. You should upgrade fully to make sure all versions are compatible with Catalina.


Yes. I want to update my Digitone but I can’t because my computer doesn’t even recognize it as something that could transfer the file. How would I go about this without my computer being able to connect?

Transfer is the program used to upgrade the digitone, overbridge has nothing to do with firmware upgrades. Do you have the current version of transfer installed?


You should be in usb midi mode not overbridge mode when updating firmware. Also make sure your midi config on the digitone has your in and out ports set to usb only so you can take advantage of turbo midi protocol.

This should be helpful (it’s c6 rather than transfer but the hardware configuration is the same on the DN)


Okay. I have updated my Digitone and the overbridge software to their latest versions respectively. Overbridge is still not picking up my Digitone. Any other suggestions?

Did you do a full uninstall of overbridge restart and then fresh install followed by a follow up restart to make sure the registry is properly edited? This is necessary between every overbridge version change.

Yes. I did. Will do it one more time for good measure with a freshly downloaded file from elektronauts.

That generally fixes it for most folks when they encounter that issue. Here’s hoping :crossed_fingers:

1 Like

Unfortunately, still nothing. Any recommendations for what I should try at this point?

Different USB ports and or cables? I had an apple USB keyboard just disappear one day and it would never come back. Tried it on two other macs worked fine. Back to original mac… nothing. Found a thread of people having the same issue from El Capitan at least if not earlier. Apple won’t acknowledge the issue. Genius Bar appointments usually just give you a new keyboard to shut the person up. There’s something weird with apple usb. :thinking:

You need to open the Overbridge engine, and then open the Digitone thingy. Basically there’s a separate program for all the Elektron devices, and you can open them without running the Overbridge engine, but it won’t actually do anything. That’s the only thing I can think of that might be causing your issue. (If you try to open the Overbridge engine it won’t open a new window, but it will run in the same area your graphics card, audio card ect is located)