+Drive not showing up on Machinedrum UW+

Hey guys! Please, I need a little help.

I had a machinedrum mkII uw+ for a while now but never used it as a sampler, as I got more confortable with the workflow I started looking on how to upload my own samples to it and noticed that my machine was not working properly as i dont have the +DRIVE menu under the files tab, no samplebanks, no snapshots. I have been searching online for anybody with issues like that and could not find anything apart from this


I tried reinstalling the firmware but it still with the same problem
Any guesses ? Does anybody know where to find another version of the OS, maybe the 1.62, so i can try and see if it works

Thanks for the help

Do you have a +Drive? Serious question…

OS here:


I do man, I have opened it before because I had that oxidation thing with the ribbon cables and the +drive is there. I even opened it up again last night to check if it was really there and properly connected. Everything looks normal

I had to ask…

Latest OS1.63; Install that and give it a go?

Might be a battery issue; or loose connections.

Yep on their website OS 1.63 is the only one you can download. My machine came out with that firmware from factory but i did re installed anyways, nothing changed

I have a new battery on it as I changed the last time I opened. It seemed really well connected i was even afraid to try to pull it off

On this link theres a guy saying this happened to him when he upgraded to OS1.63, i dont think its an hardware issue


I might have an older OS lying around on an external drive somewhere. I’ll have look for you.

1 Like

Thanks bro

Did installing an older firmware fix your problem or did you have to send it to Elektron to fix this issue? It’s so what was the cost for repairs?

It did not fixed it. I talked to them and they suggested that I should send them for repair, never got it done

have you tried the non-elektron supported OS update?

i.e. Machinedrum SPS1-UW OS 1.71 Released [ Unofficial ]

might be worth a go

1 Like

I just sold my MD last week. But I sent it to Elektron Los Angels before this covid stuff. They replaced both the +drive and the cpu. They said neither recognized any other so they changed both out. Technically it’sa brand new unit. Lucky buyer. I really regretted letting it go but it was time to set it free.

I would suggest send it in. They said my + drive was corrupt and would not be recognized by and other cpu. And the cpu would not recognize and other +drive. They replaced both. You may have the same issues but there is no way to know for sure unless you send it in. I talked to Mario whole time. And the tech was really cool

1 Like

oof that sounds expensive. How much did you spend to get it done ?