Error DSP1 Problem Elektron Machinedrum UW MK2

Hi everybody.
I have a machinedrum sps-1 UW MK2 (non +)
When I power it up, a lot of times it show this strange error screen shows up with ERROR DSP1 message.
But after some tries, it work as normal.
Anyone here had this issue? Suggestions of what may be causing this?
I’ve tried:

  • opening it up and cleaning.
  • checked the battery power inside.
  • did a full factory reset.
  • upgraded to 1.63 and now to x.07

The test mode shows everything as OK.
My last guess is to try a different power supply.

Did you reseat all the ribbon connectors? Not sure if related to this message but have heard after transit or storage can help matters.

Yeah, this is good advice. Be careful inside there though, make sure you note where all the bits go etc!

I’ve tried this. No cleaning involved, just removed each plug (including the ribbon piece) and put them together again. At first I tought it was improved, but soon after, it looked the same.
I think I’ll try some cleaning with isopropyl alcohol.