Fail to transfer samples to Digitakt

Hi there,
I received a nice collection of sounds from a friend, but have failed in uploading them to the Digitakt. If anyone of you might have a suggestion on how to solve this problem, I’d be ever so grateful.

With Transfer: At first most files were green and looked ok, but some turned red and the program said " device failed with operation". However, a directory "Transfers-210511 was created, but no sub categories are visible in the Digitakt.

With Elk-herd: I see the directory I tried to upload when I hover over the “Transfers-210511” and I can see the names of the files in the web app, but the Digitakt says there are 0 samples. When I try to re-upload the directory, the elk-herd app says that “The instrument returned error”. Is there a problem with the Digitakt itself? Should I update it in some way?

Many thanks, hope this can be solved soon.

Hi! What are the format of the samples? In general the digitakt should convert them to 44.1 16bit mono but the conversion may be failing? Can you try with some other samples and replicate your issue?


Hi, thanks for taking your time! They are .wav (but I can’t see what rate). I’ll try with another set of samples (from Elektron’s website - so they definitely should work, right?)

But it still says

“Transfer failed: Instrument returned error.”

Update: I did manage to upload one sample (one .wav file) but only directly into the +Drive which is a bit inconvenient. But not a whole directory (which should be possible by drag-and-drop)

A good night’s sleep can solve many problems, and hopefully this as well… I’ll give this a new try tomorrow. Thanks!

1 Like

Problem still not solved…I would appreciate any tips or suggestions.

Now when I try to use Elektron Transfer it just gets stuck and won’t even open the program (the little arrows beside “Connect” are just turning forever). Is there something wrong with my Digitakt or what is going on?

Are you using Windows or Mac?

On Windows, most midi devices can only have their ports opened by one program at a time.
So, close anything else that uses midi to be sure.

Hmm maybe the usb cable is junked? Or the port? Remove any hubs if you’re using one.

1 Like

Windows, only one device (Digitakt) connected.

Funny though, that I can now see the folders from the first upload I made - but no access to files (Digitakt says “0 samples”). I see them in the elk-herd overview, but not in the Digitakt itself. And it won’t let me upload them again.

If you’re on a laptop or a pre-built system, it could be that the USB ports are shared with other devices like wifi, bluetooth or a built-in webcam. Trying a different USB port could help.

To make sure a device is connected directly to the controller and no internal hub is used, go to device manager(start > windows system > this pc > right-click > more > manage > device manager) and in the menu select ‘view’ > ‘devices by connection’.
Go to ‘ACPI x64 based PC > Microsoft ACPI compl… > PCI bus or Root Complex’ and find the USB root hub.

USB Root Hub

In the above screenshot, you can see that the iLok, MicroKEY, RME 802 and iConnectMIDI4+(as a composite device) are directly connected to the root hub.
The RME ARC and my Logitech mouse have a hub in between.
The Digitakt is a composite device like the iConnectMIDI4+, but it depends on settings like Overbridge.

Can you try to delete them first with Elk-Herd?

— Problem solved —

Thanks ever so much for creative input. Went to the sample donating frind`s house who made a firmware update and magically I could access all the samples that apparently had been uploaded via transfer in the first place. I have to work on my machine karma…