[FIXED by 1.01] Digitone hardware (or software?) issue [confirmed as s/w]

Hey Digitone owners! I just got my device and it has hardware issue. When pattern selection button is pressed to choose a pattern, trigs 1 and 9 have no light and trig 2 has blue light. I will attach picture. It happens when any pattern selected except of 1 and 9. Tried hardware reset, new project. Nothing helps. Does anyone have the same issue?


Speculation on my end. But your not in chromatic mode right? I can imagine some lights go dark and the blue light being to transpose up or down.

Also reach out to Elektron support if you haven’t.

Yea, I reached support. I was not sure if it is mass problem or just my unit. Digitone has no chromatic mode like Digitakt. It is ALWAYS in chromatic mode, unless you are in step recording mode, pattern or bank change mode. It is more like Octatrack in this regards. So the problem only shows up when pattern select mode is active.

Damn all these HW issues popping up have me a little worried about preorder


That is ok for Elektron. Digitakt could barely turn on at first release. They even kept it behind the glass at NAMM2017 so no-one would breath on it. But I dont blame Elektron. They are clearly understaffed. If making semibaked products allows them making new products, I am ok with that. It would be much much worse if they run out of business trying to craft something flawless.

I guess so… Just ordered my Digitone so I hope they iron out some of this by second batch!

1 Like

I don’t think this one is a hardware issue. Mine is the same way but the lights light up @ full brightness in other modes. Seems like a firmware bug. (repeating this here)

Yea, as you have the same picture, I would agree that it seems like more software bug.

More good news. The red LED on button #2 can light up at full brightness when sequencing so it seems like once again it’s just a firmware issue. No hardware issues from what I can tell (so far).


Mine was the same during the 5 minutes it worked. Well actually it still is as the UI still works. It‘s just the sound engine/clock that‘s shot.

1 Like

This is a software issue, we thought it was fixed for 1.0 but it seems to persist. Sorry about this! We’re working on a 1.01 firmware, I will check the status on this.


Thanks for speedy response on issues , I think there will be lots of interest about quality of firmware and speed of fixes for digitone based on ‘mixed’ reaction to digitakt.

1 Like