HELP: machine drum stuck on startup

My machinedrum won’t start up, first row of leds and a blank screen flashing, anyone else had this problem?
Have taken it apart and checked connections etc, power supply suppling correct voltage (mmeter). Still bung, any help much appreciated, I don’t want a paperweight :frowning:

did you made a factory reset?

1 Like

Holding down function key doesn’t do anything, still flashing blank screen

I had this. It was the internal cabling between the UI Board and the CPU Board. I got a local technician to clean and re-crimp them and everything has worked perfectly ever since.
Cost me around £50 if I remember correctly.
Hope this helps and good luck.


I hope it’s something like that.
Easy to open MD with a 10mm Torx screw driver (better if thin, because screws are close to trigs inside), ribbon cables are quite easy to plug / unplug.
Maybe you can check that.


Thanks for the pointers, nothing looks obviously wrong - have tried disconnecting / reconnecting but will see if I can find an technician to do it properly, thanks again

1 Like

i recommend opening a ticket with elektron support. once when i had an issue they diagnosed my problem via email in an afternoon … even if it’s exactly what @Chinchilla describes they can confirm.


yeah it’s easy to disassemble the MD. but the nasty side effect is, everytime when you remove the pods, the encoders will become more and more loose. do it two to three times, then you can look for a new set of encoders…if you are lucky enough if there are some left. when i replaced the encoders of my MK1, i greased all the shafts before i pressed the pods back again on the shafts. just for the case if i’m forced to open the MD later for some reasons.

1 Like


Sorry I know Shaft and Grease but could you elaborate for a french guy ? (pictures eventually)
Don’t know what you mean with pods. I don’t understand how encoders can be worse after disassembling.

sorry my bad. pots with t not with d :slight_smile: grease/shaft…look it up on or elsewhere^^

Thanks, yea did that - they said the same thing - take it to a local technician.

On a side note, was so annoying threaded two of the small screws at the back and had to drill them out :((