How I 'repaired' my Monomachine MK1 (Pics of internals included)

So to start out I bought my Monomachine MK1 second hand a little over two years ago, It was my first Elektron box and I absolutely fell in love with it the day I laid my hands on it. Since then I use my MNM frequently, Even though I went on to get all of the other Elektron boxes (OT should be here in a week!) I still use my MNM in almost everything I do so I was pretty devastated when it broke.

Basically I turned it on a couple of nights ago and after a few minutes it froze (never had that happen before!) So I power cycled it and same thing…Worked for a few minutes and then froze…power cycled again and it wouldn’t get past the boot screen so then I rebooted it into the test screen and the test came back okay but still was a no go after reboot. I did a soft reset and that got it past the boot screen but then it froze again…power cycled, and again it wouldn’t get past the boot screen so I tried to a factory reset it froze at boot screen, tried to reload the OS…Froze!

After some research I turned up literally 3 or 4 threads on the subject (None of which were resolved)

I contacted Elektron, They got back to me and said that it’s hard to tell what would cause the issue without seeing it and he listed a number of things it might be (hardware wise) but then told me that the parts for the older machines were harder to come by so a repair from Elektron if it were to turn out to be something like the main board would not be likely plus it’s well out of warranty.

So I decided to crack it open myself. I have very little tech skills in this regard but do know the basics, I used to work QA for another major hardware company and I’ve always had the (bad?) habit of opening up and checking out every vintage synth I’ve ever owned lol

So like any good “technician” I opened a beer before opening the unit.
I referred to an old post on the elektron-users forum (I think it was ‘Why you don’t want to take the knobs off your machine’ something along those lines)
In the post the guy used a credit card and butter knife to get the knobs off.

I started there. After that there are are 6 main screws holding the faceplate on and then maybe 8-10 screws holding the main board in place.

“Oh fuck”

Once the faceplate is off and the main board is unscrewed there are three cables attached to it, One on the left hand side (black with white clips) and two on the right hand side (Orange with yellow clips)

Easily the most scary part of this whole ordeal is getting the knobs off, It’s not really that difficult but they are on there unusually tight. The key is prying them off while still retaining even pressure on the opposite site of the knob so you don’t snap the plastic potentiometer or pull it off of the board. I’m sure there is a more appropriate tool for this job than a butter knife and credit card but I had to work with what I have.

Once the unit was opened I noticed that one of the cables that connected to the main board was loose (One of the orange cables with the yellow clip) so I made sure everything was clipped in tight, looked for corrosion around the battery or PSU and did a general check of the hardware, Nothing was out of place.
So I carefully put the unit back together:


So I jammed with it for a couple hours after that and kept it running overnight with a all 6 tracks running, lots of p-locks and midi clock in/out.
Woke up this morning and it was still running :joy: :stuck_out_tongue_winking_eye:

I’m going to let it run for another 72hrs of heavy use and another 20 power cycles to declare it repaired officially.

If all goes well I’m going to assume that it was that loose cable causing the issue somehow. It is quite likely though because this happened after rearranging my studio in which I took my MNM and MD out of one of those two tier stands to have them side by side with my other Elektron boxes instead.
I noticed when the unit was open that the rackmount screw holes in the MNM align with one of those orange cables and maybe the screws that the stand came with are too long and pulled the cable halfway out?
I don’t know but that’s the best I can guess.

I’m just happy my MNM is back up and running so fingers crossed it stays that way!


Thanks for posting this anecdote. I guess it just goes to show that sometimes solutions to problems with these kinds of machines are actually quite simple. I’m glad you had the nerve to open the machine and find out! :+1:

1 Like

what an amusing, interesting, delightful and entertaining post this was of yours! …

thanks for all the effort you put into this, with the pics and video, and links, and descriptions! …

glad she is up and running for ya! … please could you make some sound design tutorial with for example the super waves ?

good luck in the future!

fuck fuck fuck fuck jesus fuck fuck fuck … I will remember the code for repairs in the future!

1 Like

awesome work here~!
really appreciate the commentary throughout the whole process. makes me that much more confident if/when the need arises. i had my mki mnm from mid 2007 to late 2012 and never had an issue. i almost feel like the mki is less cheaply built than the mkii/mkii+

1 Like

Thank you, I’m really glad you guys enjoyed it and hopefully it may be help to someone else who runs into a similar problem and/or needs to open their MNM

Whoa. haven’t logged in in a while…seeing these pics again gave me anxiety!

Just to update incase someone comes across this thread because they are looking to open and repair their MnM. The scariest part is taking off the knobs, the best advice I can give if you have to do that is go SLOW and crack a beer first.

Since this repair I’ve been using my MnM constantly. I use it in almost everything I do.

3 years since this post and it’s running strong!


To add: I’ve done exactly this after my mnm mkii was hanging on the boot screen a few months ago and it fixed it. I think it’s just about reseating cables!


Can also confirm this works. This happened to my MnM a few months back and after reseating the ribbon cables I’ve had no problem. I think it may have to be done from time to time, but it’s an easy fix if you have a set of torx screwdrivers.


I am having the same problem with the SFX60 MKII being stuck on the logo screen and staying there.
Test mode shows DSP1 Error.
I tried resetting and loading again the OS but still nothing.
I removed the cables cleaned it up well but no change.
Any ideas please?

I have the same problem as OP. The test-screen says everything’s ok.

Question! Do i need to export/save the sys before opening it?

It won’t hurt to save your sysex before doing anything. So if you can export it despite your issue, do it.

Likely obvious, but: I would not reload the saved file unless you solve the overall issue and discover your onboard patterns are corrupt in some way.