Is my MnM's step sequencer wonky?

When I enter step recording mode, via the REC+STOP button simultaneously, I am able to press any of the TRIG keys and the red light appears under each step. However no sound/note plays and it doesn’t cycle through the steps as it should (as seen in a youtube video). It seems to be more like grid recording except it doesn’t save the note to the sequence upon exiting the recording mode. Anyone knows how come the behavior I see is different to what is on youtube or as described in the manual? I am editing a fresh pattern using default kits.

I don’t have one, but on recent devices the means of entry is via REC+Stop - i’m guessing it’s the same and presumably documented so - so maybe you could look at whether the buttons are less responsive with age - just a baseless thought

you have to hold function in order to enter notes. or use an external keyboard


Thanks! Solved then. Wonder why this isn’t in the manual (the mention of having to press FUNC).

You are welcome. There is also no mention of possibility to select trigger in step recording mode by pushing it. May be entering notes worked without FUNC until firmware update at some point. I remember scratching my head on how to enter notes in step recording mode too, but I don’t remember if I found the answer somewere or solved it by accident

1 Like

Yeah that was what I was thinking too (that they made a improvement in one of the updates). But then combing through the latest 1.32B OS update PDF this morning, which lists the entire update history, I didn’t see any mention of step recording being updated or fixed. The latest manual downloaded from the website didn’t reflect anything new either. Hmm