Is upgrade on A4 bad?

I’m hours into trying to upgrade my A4 but it’s been saying ‘RECEIVING’ for hours now and I’m not sure what to do or if it ever takes this long or if I should try again.
It seems frozen as in no response from buttons

Sounds wrong to me.

But what goes on in the sending end? Which program do you use? And what is the status there?


don’t worry you should be able to reboot and resend firmware.
depending on your sysex software on your computer you may have to tweak parameters to get a stable connection


Check your USB config

  • make sure usb mode is midi only
  • MIDI IN and MIDI OUT ports should be USB only

I usually keep Global 4 for such config, that is needed for upgrades, backup or soundpacks uploads.

Transfer app makes upgrading easy, not even sure all this is still needed anymore.


Oh my god thank you Philippe-2000
I was trying to play it cool but truly the worry was slowly digesting me alive.
So now that’s it’s been even longer I can just power it down and try again?

as a double check maybe wait for somebody else to confirm before you reboot but i am pretty confindent!

first the unit recieves the new firmware files, then it engages delete/installation of the new firmware.

from what i understand you are frozen during transfer phase, meaning your current firmware is still safe and functional if you reboot.

there is only one moment where the unit shouldn’t be powered down is when the firmware is erasing/installing.


Correct, good info from @LyingDalai and @Philippe-2000 you can turn it off so long as it is not flashing (which it is not if display says RECEIVING) then check your midi settings as suggested.

When the settings are correct the whole process takes a few seconds.


Don’t forget to report, just so that other users can benefit from your own misadventure and know how you solved this! :slight_smile:

1 Like

Ok guys , i rebooted and as you all suspected it went back to normal , pre-upgrade.
Thanks for always being so prompt and helpful.

I had tried to do the whole thing on my iPhone with Sysex Base app and a three way otg cable: didn’t work.


No no no use a computer.


OK I guess this is silly but having just the last little while with analog four as well as the octatrack and Computer access And I tried transfer basically I can’t get this operating system in there and I assume that’s because I needed midi interface isn’t it I have the media interface cable otg thing That’s not being very helpful if I am I doing something wrong do I need to see six as well as transfer or do I just need a midi interface to make this work?

Hi, I would recommend that you follow the Elektron upgrade instructions by the letter (see the release notes for the new OS version an the website (Support section)). Always worked perfectly for me.


As others said, use a computer. You only need the usb cable. No midi interface required. Make sure the device is recognised in the transfer app correctly. Then set the device to os upgrade receive mode and then start the sending of the file via computer…


upgraded just recently to the latest OS (MKI) and it did take some time to have things working.
you could probably use any software that can send SysEx messages as i ended up using MIDI-OX on Windows as Transfer would not make things happen :expressionless: but had to change some of the settings in the software. on the other hand, upgrade on the AR worked using transfer but had to use the Legacy OS upgrade mode to get things working and not without checking things few times, i then realized i was trying to upgrade the AR MKI using the firmware for the MKII :smile_cat: thinking there would have been just one firmware for both models, but no…so maybe also check you’re using the right firmware for your A4.


Thanks and I love the simplicity with which you’ve described the process.
Now, when I did what you said ( plugged the a4 into pc via midi/usb [ ‘printer’ style cable ]
The Transfer app didn’t see it.
The top slot was empty and the lower one said ‘Microsoft wavetable synth’ …
Any idea what the issue is?

Check, if it is in usb only and not in overbridge mode in the system usb settings of A4

It is because since I haven’t a computer I figured that’s what I was supposed to do

Was my setting wrong?

Usb mode should be the right setting.

Can you try another usb cable?

Are you using the cable, that shipped with the a4?

As a first step you have to make sure, If the a4 is recognised by the computer at all…