Issue on master page's delay?

When I press stop two times (during playback or not) digitone’s delay effect on master page for external inputs turns off (but on the screen it seems switched on). Playing some notes inside internal tracks and not from midi tracks (by hand or sequencer) is the only way to turn it on again. For example if I have a clean project with notes inside midi tracks only, and I press stop two times turns delay off permanently, also if I press play again.
Is there a way to resolve this?

apart from resetting the playback head , it’ll be a kill-all safety thing to ensure runaway feedback doesn’t deafen folk etc

ps bugs are ideally explored within the bug reports thread, I wouldn’t expect that this is a bug, only Elektron can tell you what expected behaviour is, but it seems a reasonable prospect it’s intentional

1 Like

Two times stop is basically the panic button on all (?) Elektrons. I think it works on all Elektrons… Octatrack will also send all notes off command on all midi tracks when you double tap stop.

Should be in the manual.

Edit, indeed it is:
“Quickly press [STOP] twice to stop playback of all tracks and the fade out of the send effects.”

Page 30, Digitone pdf manual.


ok, thank you, my dubt is exactly about panic: probably it should panic the effect and restore it on immediately for further plays, and not switch it off permanently (I repeat, the only way to have delay again on is playing some internal notes, it should turn on also with MIDI track notes in my opinion).

If you have the delay feedback set very high to the point you lose control and the delay self-oscillates, resuming playback (or initiating the audio engine again) immediately after double stop has been executed wouldn’t make sense. The delay would go back to speaker destroying havoc in a few seconds.

Same for system freezes, glitches etc. If it would automatically ‘unlock’ the audio engine, you would only have a few seconds to turn the volume down…

I’m surprised the Digitone does not send a all notes off message on all midi tracks…

Sorry, for the edits…

Probably I didn’t explain well (probably for my bad english). I start with two empty projects and I add some notes, the first has some notes inside an internal track, the second has some notes inside a midi track. Now if I press two times stop and play again (immediatly or not) we have delay switched on again in the first project, but it is switched off in the second.
I ask just to understand the reason of this choice.
(However I understand that I should pay attention to not press stop two times, somentimes I do it accidentally)

1 Like

Ok, sorry. Then I really didn’t understand the problem! :slight_smile:

Of course everything should work normally again when you press play!

Have you tried to switch the Digitone off and on again? Sometimes that solves weird issues.
Any midi input, that could interfere with parameters?

What you can try is save the project to a new slot (Global menu - Manage Projects - Save to), load that project and check if it works like it should.

And you really mean two different projects, not patterns, right?

I think it is a known bug. My DK is the same. There’s been some chat about it on another thread. Can’t remember which one, probably the bug reports thread.

thank you, yes I tried these. However, it happends within a project on different patterns also.

I searched and googled but I didn’t find…I look for it better

Here it is.


thank you!

Just a thought, but maybe this could prevent projects from getting affected by that bug:

So when you want to start with a new project,
instead of creating a new project in the global menu, you load a project that does not have the bug and then use the ‘Save to…’ command in the project manager to save it to a new slot. You load that project and then clear all patterns in order to have a blank project you can work start with.

If the source project did not have the bug, I think there might be a good chance that if you save it to a new slot, the project there won’t have it either.

Anyone already tried that?

thank you @Schnork but actually it happends everywhere and inside any project, and as @DampSquid suggested it is a known bug. I will continue in that thread.

1 Like

It’s actually not a bug. I spoke with support a while ago. In order to get the effects to trigger again you must press note key. Kinda of annoying but if you have a muted track not so bad.


Wow, that should be stated somewhere really, because as it seems for me it is quite a big issue and annoying bug, especially for live situation. How come chorus and reverb work just fine as master sends from input, and delay works only if there is and internal note input? What if I want to start track just with an external synth with the delay - I need to think about and press a note that is heard unless you set volume to 0 on the track and then change it back… that is kinda lame.

Only after you have double pressed stop (shut off notes and fx), the delay needs a note to be active again.

If you do not double tap the stop button, delay will function like a normal delay effect would.

So this is not a bug, but a design decision, or at least a result of a design decision. Delay is unique in that it’s feedback can go higher than unity, which can quickly destroy speakers, headphones, and ears. The double tap stops the delay entirely. The only way it is restarted is by one of the internal tracks triggering. It would be nice if there were an option to detect audio coming in and start the delay if it is stopped.

1 Like